SearchFilterView

SearchFilterView v1.00
Copyright (c) 2010 Nir Sofer
Web site: http://www.nirsoft.net

Description

When you search the content of files with Windows search, it uses the right search IFilter plugin according to the file extension. This utility allows you to easily view the search filters installed on your system and the file extensions that are associated with them, as well as it allows you to easily add or remove file extensions for these filters.

System Requirements

This utility works on any version of Windows, starting from Windows 2000 and up to Windows 7. Both 32-bit and x64 systems are supported.

Using SearchFilterView

SearchFilterView doesn't require any installation process or additional dll files. In order to start using it, simply run the executable file - SearchFilterView.exe

The main window of SearchFilterView contains 2 panes: the upper pane displays the list of all installed filters. When selecting a filter in the upper pane, the lower pane displays the list of all extensions associated with the selected filter in the upper pane.
When selecting a filter, you can select one or more extensions in the lower pane and then press F8 (Remove Selected Extensions From Filter) to remove the selected extensions. You can also press F7 (Add Extensions To Filter) and then type the list of extensions that you want to add to the selected filters.

Notice: When you add/remove extensions for a filter, the changes only take effect after you log off and then log on.

Translating SearchFilterView to other languages

In order to translate SearchFilterView to other language, follow the instructions below:
  1. Run SearchFilterView with /savelangfile parameter:
    SearchFilterView.exe /savelangfile
    A file named SearchFilterView_lng.ini will be created in the folder of SearchFilterView utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run SearchFilterView, and all translated strings will be loaded from the language file.
    If you want to run SearchFilterView without the translation, simply rename the language file, or move it to another folder.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com