ProcessTCPSummary

ProcessTCPSummary v1.01
Copyright (c) 2018 Nir Sofer
Web site: http://www.nirsoft.net

Description

ProcessTCPSummary is a simple tool for Windows that displays a summary of all process that have TCP connections or listening UDP ports. For every process, this tool displays the total number of TCP connections, number of TCP connections for each status (Established, Listening, Syn-Sent, Syn-Received...), number of IPv4 TCP connections, number of IPv6 TCP connections, common port numbers, and more...
If you run ProcessTCPSummary as Administrator, you can also watch the number of TCP/UDP bytes sent and received by every process as well as the current send/receive speed.

System Requirements

This tool works on any version of Windows, starting from Windows XP and up to Windows 10. Both 32-bit and 64-bit versions of Windows are supported. On Windows Vista and later, if you want to view the full path of system processes or you want to view the sent/reveived bytes information , you have to run ProcessTCPSummary as Administrator.

Versions History

  • Version 1.01:
    • Added /cfg command-line option to start ProcessTCPSummary with the specified config file.
    • Added 'Add Header Line To CSV/Tab-Delimited File' option (Turned on by default).
  • Version 1.00 - First release.

Start Using ProcessTCPSummary

This utility doesn't require any installation process or additional DLL files. In order to start using it, simply run the executable file - ProcessTCPSummary.exe
After running ProcessTCPSummary, the main window displays a summary of TCP connections for every process.

Command-Line Options

/cfg <Filename> | Start ProcessTCPSummary with the specified configuration file. For example: ProcessTCPSummary.exe /cfg "c:\config\pts.cfg" ProcessTCPSummary.exe /cfg "%AppData%\ProcessTCPSummary.cfg"
/stext <Filename> | Save the process TCP Summary into a simple text file.
/stab <Filename> | Save the process TCP Summary into a tab-delimited text file.
/scomma <Filename> | Save the process TCP Summary into a comma-delimited text file (csv).
/sjson <Filename> | Save the process TCP Summary into a JSON file.
/shtml <Filename> | Save the process TCP Summary into HTML file (Horizontal).
/sverhtml <Filename> | Save the process TCP Summary into HTML file (Vertical).
/sxml <Filename> | Save the process TCP Summary into XML file.
/sort <column> | This command-line option can be used with other save options for sorting by the desired column. The <column> parameter can specify the column index (0 for the first column, 1 for the second column, and so on) or the name of the column, like "TCP Established" and "Total TCP". You can specify the '~' prefix character (e.g: "~TCP Listening") if you want to sort in descending order. You can put multiple /sort in the command-line if you want to sort by multiple columns.

Translating ProcessTCPSummary to other languages

In order to translate ProcessTCPSummary to other language, follow the instructions below:
  1. Run ProcessTCPSummary with /savelangfile parameter:
    ProcessTCPSummary.exe /savelangfile
    A file named ProcessTCPSummary_lng.ini will be created in the folder of ProcessTCPSummary utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run ProcessTCPSummary, and all translated strings will be loaded from the language file.
    If you want to run ProcessTCPSummary without the translation, simply rename the language file, or move it to another folder.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this and you don't sell it or distribute it as a part of commercial product. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com