HotKeysList

HotKeysList v1.00
Copyright (c) 2015 Nir Sofer
Web site: http://www.nirsoft.net

Description

HotKeysList is a simple tool for Windows that displays the list of hot keys that are currently registered on your system. You can use this tool to easily determine which hot keys on your system are available to use.

System Requirements

This utility works on any version of Windows, starting from Windows 2000 and up to Windows 8. Both 32-bit and 64-bit systems are supported.

Start Using HotKeysList

HotKeysList doesn't require any installation process or additional dll files. In order to start using it, simply run the executable file - HotKeysList.exe
After running it, the main window of HotKeysList displays the list of all hot keys currently registered on your system.

Command-Line Options

/stext <Filename> | Save the list of registered hot keys into a simple text file.
/stab <Filename> | Save the list of registered hot keys into a tab-delimited text file.
/scomma <Filename> | Save the list of registered hot keys into a comma-delimited text file (csv).
/stabular <Filename> | Save the list of registered hot keys into a tabular text file.
/shtml <Filename> | Save the list of registered hot keys into HTML file (Horizontal).
/sverhtml <Filename> | Save the list of registered hot keys into HTML file (Vertical).
/sxml <Filename> | Save the list of registered hot keys into XML file.

Translating HotKeysList to other languages

In order to translate HotKeysList to other language, follow the instructions below:
  1. Run HotKeysList with /savelangfile parameter:
    HotKeysList.exe /savelangfile
    A file named HotKeysList_lng.ini will be created in the folder of HotKeysList utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run HotKeysList, and all translated strings will be loaded from the language file.
    If you want to run HotKeysList without the translation, simply rename the language file, or move it to another folder.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this and you don't sell it or distribute it as a part of commercial product. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com