CountryTraceRoute

CountryTraceRoute v1.28
Copyright (c) 2012 - 2017 Nir Sofer
Web site: http://www.nirsoft.net

Description

CountryTraceRoute is a Traceroute utility, similar to the tracert tool of Windows, but with graphical user interface, and it's also much faster than tracert of Windows. CountryTraceRoute also displays the country of the owner of every IP address found in the Traceroute.
After the Traceroute is completed, you can select all items (Ctrl+A) and then save them into csv/tab-delimited/html/xml file with 'Save Selected Items' option (Ctrl+S) or copy them to the clipboard (Ctrl+C) and then paste the result into Excel or other spreadsheet application.

System Requirements

This utility works on any version of Windows, starting from Windows 2000 and up to Windows 10. Both 32-bit and x64 systems are supported.

Known Limitations

  • Currently, IPv6 is not supported by this tool.
  • This tool displays the country name of the owner of every IP address found in the Traceroute. Be aware that the actual country where the IP address is located might be different from the country of the IP address owner.

Versions History

  • Version 1.28:
    • The hosted name/ip address is now displayed in the window title.
  • Version 1.27:
    • Fixed bug: CountryTraceRoute crashed when it failed to resolve the specified host name.
    • Updated the internal IP to country database.
  • Version 1.26:
    • Updated the internal IP to country database.
  • Version 1.25:
    • Updated the internal IP to country database.
    • Added option to select the font of the main List-View.
  • Version 1.23:
    • Fixed bug: CountryTraceRoute failed to remember the last size/position of the main window if it was not located in the primary monitor.
  • Version 1.22:
    • Fixed to display the main window properly when using large fonts settings.
  • Version 1.21:
    • Fixed bug: CountryTraceRoute crashed when specifying a large maximum hops number.
  • Version 1.20:
    • Added command-line options to start the Traceroute instantly with the specified host name.
  • Version 1.16:
    • Fixed the flickering appeared while updating the Traceroute information.
  • Version 1.15:
    • CountryTraceRoute now remembers the last 20 host-names/IP addresses that you previously queried and you can select them from a combo-box.
    • The host-name combo-box is now focused on start.
  • Version 1.10:
    • Added 'Put Icon On Tray' option.
    • You now copy & paste full URL into the host name text-box, and CountryTraceRoute will automatically extract the host name from the URL.
  • Version 1.06:
    • Added 'Stop' button.
    • Added 'Mark Odd/Even Rows' option, under the View menu. When it's turned on, the odd and even rows are displayed in different color, to make it easier to read a single line.
  • Version 1.05:
    • Added support for GeoLite City database. You can now download the GeoLite City database (GeoLiteCity.dat.gz), put it in the same folder of CountryTraceRoute.exe, and CountryTraceRoute will automatically use it to get the country/city information for every IP address.
  • Version 1.00 - First release.

Start Using CountryTraceRoute

CountryTraceRoute doesn't require any installation process or additional dll files. In order to start using it, simply run the executable file - CountryTraceRoute.exe

In the main window of CountryTraceRoute, type the desired host name or IP address, the maximum number of hops, the timeout value in milliseconds, and then press the 'Go' button (or press the Enter key) to start the traceroute.

Using External IP To Country File

CountryTraceRoute has an internal IP to country database to display the country name for every IP address found in the Tarceroute. However, if you want to to use the most updated IP to country database, you can download the latest IP To Country file from the following link: http://software77.net/geo-ip/
If you put the IpToCountry.csv file downloaded from this Web site in the same folder of CountryTraceRoute, it will automatically be loaded by CountryTraceRoute and it will be used instead of the internal IP database.

Using GeoLite City database

The GeoLite City database is much larger than the internal IP-Country database and for many IP addresses, it also contains city information. You can download the database from this Web site. You should download the GeoLite City database in Binary / gzip format (GeoLiteCity.dat.gz) because CountryTraceRoute can only read this file format.

In order to starting using this database, simply copy GeoLiteCity.dat.gz (or GeoLiteCity.dat after decompressing it) into the folder where CountryTraceRoute.exe is located, and it'll automatically be loaded when you run the CountryTraceRoute tool.

Command-Line Options

/Start <HostName> | Starts the Traceroute with the specified host name, for example: CountryTraceRoute.exe /Start www.google.com
/MaxHops <Number> | Specifies the maximum number of hops.
/Timeout <Number> | Specifies the timeout value in milliseconds.

Translating CountryTraceRoute to other languages

In order to translate CountryTraceRoute to other language, follow the instructions below:
  1. Run CountryTraceRoute with /savelangfile parameter:
    CountryTraceRoute.exe /savelangfile
    A file named CountryTraceRoute_lng.ini will be created in the folder of CountryTraceRoute utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run CountryTraceRoute, and all translated strings will be loaded from the language file.
    If you want to run CountryTraceRoute without the translation, simply rename the language file, or move it to another folder.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this and you don't sell it or distribute it as a part of commercial product. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com