Ââåäåíèå

Введение

Благодарю вас за использование Hard Disk Sentinel. Эта программа создана для проверки состояния жёсткого диска, его температуры и здоровья. Кроме того, она может показать возможные проблемы и сбои в работе, и предсказать отказы жёсткого диска. Используя эту программу, Вы сможете избежать серьёзных проблем, связанных с потерей данных.

Пожалуйста, тщательно прочитайте эту документацию. В следующих главах будут описаны все функции и характеристики Hard Disk Sentinel.

Перевод выполнен Андреем Николаевым. По всем вопросам и пожеланиям просьба связываться с автором по e-mail, указав в теме письма: "Перевод Help HDS".


Æ¸ñòêèå äèñêè, S.M.A.R.T.

Жёсткие диски

Компьютерные жёсткие диски имеют один или несколько физических дисков. Головка чтения/записи, которая двигается над этим диском, выполняет операции чтения, записи и удаления данных.

Так как объём данных на жёстком диске постоянно увеличивается, то получается, что они загружаются всё в меньшие и меньшие области на дисковой поверхности. Любое маленькое (даже микроскопическое) повреждение или грязь на поверхности сильно уменьшают возможность получить доступ к важным данным. Диски герметично закрыты для предохранения от воздействия влажности и грязи дискового блока.

Этот процесс не всегда заканчивается благополучно. Возможно, что некоторые области дисковой поверхности не читаемые или недоступны для записи из-за небольшого повреждения или грязи. В этом случае, жёсткий диск отмечает эту область как плохую и никогда не будет использовать эти сектора для операций чтения или записи. Если в этой области хранились данные, жёсткий диск сначала попробует прочитать и скопировать их в специальную резервную область. После завершения процесса, все запросы доступа к старым областям будут переадресованы в новую. К проблемной же области нельзя будет получить доступ даже после полного переформатирования диска.

Это кажется хорошим, поскольку проблема якобы автоматически решена. Но пользователь не знает о постоянно ухудшающемся состоянии жёсткого диска, пока не будет поставлен перед фактом его отказа и полной потере данных.

Возможны и другие проблемы, которые ухудшают состояние жёсткого диска. Высокая температура, неправильное электропитание, вибрация или механическое воздействие могут серьёзно повредить жёсткий диск. Многие из таких проблем будут обнаружены, если использовать Hard Disk Sentinel, и потерю данных, вызванную этими проблемами, можно избежать.

S.M.A.R.T.

Технология S.M.A.R.T. (Self-Monitoring Analysis and Reporting Technology - Технология Самоконтроля и Составления Диагностических Отчётов) была разработана компанией IBM для контроля за состоянием диска, использующая при этом различные методы и устройства. Один жёсткий диск ATA может иметь до 30 таких измерительных величин (атрибутов). Некоторые из них прямо или косвенно затрагивают состояние здоровья жёсткого диска, а другие содержат статистическую информацию.

Сегодня все современные жёсткие диски IDE/Serial ATA/SCSI обладают технологией S.M.A.R.T. Но это не единый стандарт, так что значение атрибутов может различаться у разных производителей. Поэтому необходим независимый метод анализа здоровья, чтобы определить реальное состояние любого жёсткого диска. Hard Disk Sentinel может сделать это, смотрите раздел методы вычисления состояния.

Множество атрибутов задействовано всеми производителями, и они используют для этого один и тот же способ. Именно поэтому, например, возможно определить температуру и время работы многих жёстких дисков. Эти значения, как и многие другие, контролируются этим приложением.

Согласно спецификациям S.M.A.R.T., при обнаружении проблемы, жёсткий диск должен отработать около 24 часов, чтобы пользователь успел выполнить резервное копирование данных. Но во многих случаях этого времени оказывается недостаточно - вот почему важно заранее распознать эти проблемы и подготовиться к их решению.

Примечание: некоторые контроллеры жёсткого диска или драйвера предотвращают чтение и проверку значений S.M.A.R.T. В этих случаях, текущие здоровье, температура или другой показатель не могут быть определены для данного жёсткого диска. Пожалуйста, свяжитесь с производителем контроллера для обновления драйвера или программного обеспечения. Невозможно определить состояние S.M.A.R.T. внешних жёстких дисков шин USB/FIREWIRE и аппаратных RAID массивов.


Óñòàíîâêà

Установка

Пользователям Windows 98/98SE/ME: Эти операционные системы не имеет драйвера S.M.A.R.T., загруженного по умолчанию. Перед инсталляцией скопируйте файл Smartvsd.vxd из папки Windows\System в папку Windows\System\IoSubsys и перезагрузите компьютер. Пожалуйста, устанавливайте Hard Disk Sentinel только после этой процедуры. Решение проблемы описано на странице Майкрософт.

После загрузки, приложение может быть установлено на любом физическом, не сменном жёстком диске. По умолчанию, предлагается установка в папку Program files. Не рекомендуется и не поддерживается установка на сменный носитель (например, флэш-память), так как приложение постоянно сохраняет все текущие значения в своей базе данных (в инсталляционной папке). В этой базе данных можно отыскать и графически отобразить предварительно измеренные значения.

Во время инсталляции, иконка приложения может быть создана на рабочем столе и в панели быстрого запуска. Hard Disk Sentinel автоматически запустится после установки, если пользователь не отключит эту опцию.

Значения по умолчанию

Окно состояния отображается автоматически в верхнем правом углу экрана. Оно содержит информацию о моделях, значениях температуры и здоровья установленных жёстких дисков. Главное окно также отображается, обеспечивая пользователя подробной информацией. Ко всем опциям Hard Disk Sentinel можно обратиться из этого окна.

По умолчанию, приложение не выдаёт никаких тревог/предупреждений, но все найденные проблемы регистрируются в логе жёсткого диска.

Hard Disk Sentinel автоматически заносит запись в реестр, чтобы в следующий раз загрузиться вместе с Windows. Таким образом, он начинает контролировать состояние жёсткого диска вместе с запуском операционной системы. Конечно эта опция может быть отключена.


Êîìïîíåíòû ïðèëîæåíèÿ

Компоненты приложения

Основные компоненты Hard Disk Sentinel описаны в следующих разделах:

· Окно состояния

· Иконка в трее

· Иконка диска

· Быстрое меню

· Главное окно

· Конфигурация

· Конфигурация и резервное копирование (доступно только в версии PROFESSIONAL)


Îêíî ñîñòîÿíèÿ

Окно состояния

После установки и запуска окно состояния автоматически отображается в правом верхнем углу. В нём содержится информация о моделях, значениях температуры и здоровья установленных жёстких дисков. Оно всегда отображается поверх остальных окон, чтобы была возможность контролировать текущее состояние дисков.

· Если указатель мыши переместить на это окно, то в его верхнем правом углу отобразится небольшая кнопка (красная с крестиком). Окно закроется, если пользователь щёлкнет по ней левой кнопкой мыши.

· Если нажать левой кнопкой мыши на окне, появится список логических дисков с информацией о свободном месте на каждом из них. Если щёлкнуть на каком-нибудь логическом диске, то он автоматически откроется в Проводнике Windows. Повторное нажатие на окне состояния, скроет эту информационную панель.

· Можно переместить окно состояния в любую точку экрана, удерживая нажатой левую кнопку мыши и перемещая его в нужное место. По умолчанию, окно не может быть перемещено за пределы экрана (оно выровнено по его краям), но эту опцию можно отключить. В этом случае окно можно будет переместить (полностью или частично) за пределы экрана.

· После двойного щелчка левой кнопкой, детали жёсткого диска, находящегося под указателем мыши, отобразятся в главном окне приложения.

· При использовании правой кнопки мыши, отобразится быстрое меню (Таким же образом его можно отобразить, используя иконку в трее. Это полезно, если окно состояния скрыто.)

Примечание: Информация, отображаемая в окне состояния и его расположение могут быть сконфигурированы. Приложение автоматически сохраняет изменения и расположение окна и при следующем запуске оно будет отображено согласно новой конфигурации (или не отображено вообще, если предварительно было скрыто).


Èêîíêà â òðåå

Иконка в трее

В нижнем правом углу, около часов, можно отобразить состояние жёстких дисков, используя иконку Hard Disk Sentinel в системном трее. После установки программы, иконка с информацией о температуре отображается для каждого жёсткого диска (если эту функцию поддерживает жёсткий диск). Приложение отображает различную температуру, используя следующие цвета: ниже 40 градусов - иконка зеленого цвета, между 40 и 50 - жёлтая и выше 50 - красная. Конечно, эти пороги и цвета можно конфигурировать, основываясь на собственных предпочтениях.

Когда два или более дисков имеют свои иконки в системном трее, то не совсем ясно, какая иконка какому диску принадлежит. Обычно они отображаются по порядку жёстких дисков (слева направо), но в некоторых случаях могут располагаться по-другому из-за операционной системы или какой-нибудь программы, использующей свою иконку в трее. Если указатель мыши переместить на любую иконку Hard Disk Sentinel в системном трее, то отобразится всплывающая подсказка с информацией о номере, модели, здоровье и температуре данного жёсткого диска (всё что отображено для него в окне состояния).

Если дважды щёлкнуть левой кнопкой мыши на любой иконке диска в трее, то в главном окне отобразится подробная информация обо всех установленных жёстких дисках.

Щелчок правой кнопкой на иконке диска в системном трее отобразит быстрое меню с наиболее часто используемыми функциями.


Èêîíêè äèñêà

Иконки диска

На иконках логических дисков Hard Disk Sentinel постоянно отображает их состояние (здоровье, которое может быть отличным, удовлетворительным или плохим) и объём используемого места. Так же, текущее состояние дисков отображается и в других приложениях (например, Проводник Windows).

Эта опция особенно полезна, если в системе установлено два или более жёстких дисков, или если окно состояния не отображено. Используемый объём отображается постепенно за 16 шагов. Если он увеличивается на логическом диске, то индикаторная полоска становится сначала жёлтой, а затем красной.

Примечание: Использование отображения объёма зависит от установки порога свободного места на диске. Это возможно, если настроить разные уровни порогов свободного места для каждого логического диска. При установленном более высоком пороге, индикаторная полоска достигнет жёлтой или красной области гораздо быстрее.

Символ, относящийся к здоровью жёсткого диска, отображается в нижнем правом углу иконок. По умолчанию, этот символ зелёный, если здоровье диска больше 50 %. Между 25 % и 50 % - отображается жёлтый восклицательный знак, а ниже 25 % - красный символ X. Конечно, эти пороговые значения могут быть сконфигурированы по собственному усмотрению.

Примечание: символ здоровья отображается только на дисках, поддерживающих технологию S.M.A.R.T., где можно обнаружить текущее состояние здоровья. Для логических дисков, находящихся на внешних жёстких дисках с интерфейсом USB/FIREWIRE и удалённых накопителях, возможно отображение информации только об использовании объёма. (По умолчанию, эта опция отключена, но её можно включить через панель конфигурации на вкладке управление дисками). Информация о здоровье не отображается под операционными системами Windows 98/98SE/ME.

Для того, чтобы отображать текущее состояние дисков, требуется периодическая проверка их здоровья и используемого объёма. Медленные устройства или накопители (например, некоторые типы карт или сетевых накопителей) могут потребовать больше времени для обнаружения и это может увеличить время отклика приложения или замедлить работу системы. В таких случаях, эта опция должна быть полностью или частично отключена для этих накопителей. Это можно настроить на вкладке управление дисками через панель конфигурации.

Hard Disk Sentinel должен быть активен (запущен), чтобы отображать символы здоровья и используемого места на иконках логических дисков. Если программа не запущена, то эта дополнительная информация отображена не будет.


Áûñòðîå ìåíþ

Быстрое меню

Это меню отобразится, если пользователь нажмёт правой кнопкой мышки на окне состояния или иконке в системном трее. Из него возможно следующее:

· Открыть главное окно Hard Disk Sentinel.

· Показать или скрыть окно состояния (доступна соответствующая опция).

· Открыть раздел Конфигурации и установить свои предпочтения.

· Посмотреть историю температуры жёсткого диска.

· Открыть Помощь.

· Отобразить окно О Программе, в котором содержится информация о текущей установленной версии, имя зарегистрированного пользователя, ссылка на сайт программы, имя и адрес электронной почты человека, который сделал перевод интерфейса.

· Включить или отключить звуковые предупреждения в текущей сессии. Если эта функция разрешена на вкладке Предупреждения, то при найденной проблеме (например, перегрев жёсткого диска, недостаточный объём свободного места и т.д), приложение воспроизведёт звуковой сигнал. (Дополнительно, этот сигнал может повторяться, пока пользователь не подтвердит, что он предупреждён, нажав на эту опцию мышкой). При использовании этой функции, звуковые предупреждения могут быть отключены для текущей сессии. После перезапуска приложения, предупреждения автоматически включатся снова - лучше использовать эту опцию, чем отключать её на вкладке предупреждений.

· Выйти из программы Hard Disk Sentinel. Этот выбор остановит запущенное приложения, что приведёт к отмене мониторинга состояния жёстких дисков.

Примечание: при следующем запуске, изменения в здоровье после последнего запуска будет исследовано и зарегистрировано в протоколе. Эта опция может использоваться, если Hard Disk Sentinel нельзя запустить постоянно, но можно выполнять периодически, чтобы проверить состояние дисков (изменения в их здоровье).


Ãëàâíîå îêíî

Главное окно

Из главного окна Hard Disk Sentinel можно получить доступ ко всем функциям и характеристикам программы, используя основное меню или кнопки быстрого доступа.

Главное меню имеет следующие опции:

· Файл: отсюда можно получить доступ к Конфигурации управлением шумом, Короткой и Расширенной диагностикам, Тесту подводу головке, Тесту поверхности, Проверке новой версии и возможности закрыть программу.

· Вид: здесь можно выбрать необходимую информационную панель для интересующего жёсткого диска.

· Отчёт: здесь можно создать различного вида отчёты. Возможно простое сохранение отчёта (для последующего открытия) или для немедленной отправки его по e-mail на любой адрес. По умолчанию, показаны сконфигурированные адрес получателя и опции почты, которые используются, для передачи e-mail отчёта.

· Конфигурация: характеристики и функции приложения могут быть сконфигурированы в этом окне. Опции расположены по категориям.

· Помощь: отсюда можно посмотреть разделы помощи, посетить наш сайт, отправить нам e-mail, приобрести и ввести регистрационный ключ или открыть информационное окно О Программе.

Если курсор мыши навести на кнопки быстрого доступа под главным меню, то функция кнопок будет отображаться во всплывающих подсказках. Используя кнопки, можно выполнить следующие задачи:

· обновить состояние всех жёстких дисков, независимо от заранее настроенного периода обновления.

· очистить список от предыдущих предупреждений, чтобы эти предупреждения, в том числе и звуковые, появились вновь.

· скрыть или показать окно состояния.

· настроить уровни шума жёсткого диска (если поддерживается). Более высокий акустический уровень означает больше искажений, но лучшую производительность, пониженный уровень означает меньше искажений, но более медленную производительность.

· запустить тест подвода головки диска на производительность, шум и температуру. Тест можно эффективно использовать для анализа температурных режимов жёсткого диска.

· сделать анализ дисковой поверхности. Включает в себя 5 различных тестов. Перед запуском любого из тестов необходимо ОБЯЗАТЕЛЬНО ознакомиться с подробной информацией, которая располагается внизу тестового окна.

· выполнить внутренние тесты жёсткого диска, чтобы проверить критические компоненты и выявить любые скрытые проблемы.

· онлайн сравнение значений S.M.A.R.T. этого диска со значениями дисков такой же модели.

· сохранить полный отчёт в текстовом или HTML формате.

· отправить полный отчёт на e-mail. Формат отчёта, текстовый или HTML, может быть выбран.

· отправить тестовый отчёт разработчику, чтобы помочь дальнейшей разработке программы. Полезно для проверки и обнаружения проблем.

· открыть окно Конфигурации.

· отключить или включить звуковых предупреждений во время текущего сеанса. Если выбрана опция "Повтор звукового сигнала", то эта кнопка может использоваться, чтобы включить или отключить дальнейшие звуковые предупреждения.

· открыть текущий файл помощи.

· просмотреть окно О Программе.

Под быстрыми кнопками слева отображены установленные физические жёсткие диски (верхняя панель) и доступные логические диски (нижняя панель). Горизонтальный разделитель между верхним и нижним списками можно использовать, чтобы изменить размер панелей. Если какой-нибудь физический или логический диск выбрать левой кнопкой мыши, то подробности диска будут отображены справа на большой информационной панели.

В селекторных панелях список дисков периодически обновляется. Таким образом, быстрая дисковая информация (температура, здоровье или свободное место) отражает фактическое, обновлённое состояние.

Разделитель между селекторной и информационной панелями можно использовать, чтобы изменить размеры этих областей.

Примечание: приложение автоматически сохраняет позицию и размер окна и позицию разделителей. Таким образом, при запуске программы окно будет отображено так же, как оно было использовано в последний раз.

На информационной панели отображаются детали выбранного физического или логического дисков.


Èíôîðìàöèÿ ôèçè÷åñêîãî äèñêà

Информация физического диска

Есть много различных информационных страниц, доступных для физического диска. Их можно просматривать, используя вкладки или выбрав нужную страницу в меню Вид.

· Обзор

· Температура

· S.M.A.R.T.

· Информация

· Лог

· Производительность диска

· Предупреждения


Îáçîð

Обзор

Здесь отображаются производительность и уровень здоровья выбранного жёсткого диска. (Нажмите на ссылки, чтобы узнать методы вычисления этих значений).

Затем отображается текстовое описание текущего состояния. Анализируя атрибуты S.M.A.R.T., которые поддерживаются диском, Hard Disk Sentinel оценивает эти значения, а затем создаёт и отображает текстовую оценку. Здесь содержится описание проблем, которые произошли за всё время работы жёсткого диска (вращение, ошибки передачи данных и т.п.). Цвет фона этой области (зелёный, жёлтый или красный) указывает на состояние здоровья диска. Текстовая область может содержать ценные советы для исправления текущих проблем, поэтому мы рекомендуем подробно их изучить.

В середине показаны время работы и приблизительная оценка оставшегося времени жизни. Процесс измерения и вычисления этих значений описан в приложении.

Внизу панели отображён график ранее оценённых значений здоровья диска. Hard Disk Sentinel сохраняет наихудшее значение здоровья, измеряемое каждый день, и эти значения показаны на графике. Если приложение используется в течение длительного периода, можно воспользоваться колесом прокрутки под графиком, чтобы пролистать до нужной даты. График может быть сохранён как изображение (в формате BMP или JPG), если нажать на иконку в верхнем левом углу в области графика.


Òåìïåðàòóðíàÿ ñòàòèñòèêà

Температурная статистика

На этой странице можно исследовать текущие, средние и максимальные температуры, зафиксированные сегодня.

Основанная на температурных значениях, отображена текстовая оценка (подобно оценке здоровья диска). В случае высокой температуры, приложение может дать советы, как избежать проблем.

Во многих случаях температурный датчик на жёстком диске не точен. Рекомендуется выполнить процедуру калибровки температуры (этот текст будет отображаться, пока температурное смещение (даже 0) не будет установлено для жёсткого диска).

Внизу этой страницы отображены предыдущие значения, зафиксированные во время текущего сеанса. Это необходимо для вычисления среднего значения и максимальной температуры, измеренных за предыдущие дни. Если приложение используется в течение длительного периода, можно воспользоваться колесом прокрутки под графиком, чтобы пролистать до нужной даты. График может быть сохранён как изображение (в формате BMP или JPG), если нажать на иконку в верхнем левом углу в области графика.


S.M.A.R.T.

На странице S.M.A.R.T. отображён список атрибутов для выбранного жёсткого диска интерфейсов IDE или Serial ATA. Все жёсткие диски могут иметь до 30 различных атрибутов, которые служат для отражения своего фактического состояния. Список атрибутов определён изготовителем, но не все жёсткие диски поддерживают их полностью. Список фиксированный, в него нельзя добавить или удалить атрибуты после выпуска диска с завода. Список может различаться для разных жёстких дисков одного производителя, но у одинаковых дисков он обычно один и тот же.

Список начинается слева направо с идентификатора (номера) от 0 до 255. Атрибут непосредственно затрагивает состояние здоровья жёсткого диска и может достигать критического уровня. Hard Disk Sentinel показывает перед числом зелёную отметку (верный) или красную (неверный).

Далее следует имя атрибута, если оно известно. Большинство атрибутов широко используются почти всеми производителями, но смысл и значение некоторых атрибутов неизвестны, поскольку изготовитель не предоставляет такую информацию.

Колонка Порог содержит величину порога для атрибута. Если в колонке Значение содержится число меньшее значения порога, то атрибут неверен. Если атрибут критический, то в этом случае в начале этой строки отображается красный значок X. В колонке Наихудшее отображено самое худшее, когда-либо измеренное значение.

В колонке Состояние отображено текущее состояние атрибута. Это может быть:

· OK: значение больше порогового. Проблем нет.

· OK (Всегда проходит): порог является нулевым, так что атрибут не может иметь меньшее значение. Обычно отображается для атрибутов, указывающих только статистическую информацию.

· Сбой: для критического атрибута значение превысило порог (значение меньше порогового).

· Превышение предела использования: для некритического атрибута значение превысило порог (значение меньше порогового).

В колонке Данные отображены исходные значения. Эти значения не оценены жёстким диском, в отличии от столбца Значение, содержащего оценённое число, которое зависит от производителя и жёсткого диска. Эти значения отображены в шестнадцатеричном формате, но можно выбрать десятичные значения из меню, вызванного нажатием правой кнопкой мышки на вкладке S.M.A.R.T.

Исследуя состояние диска и вычисляя значение здоровья, рекомендуется проверить исходные значения. Это нужно для того, чтобы иметь объективную информацию о состоянии жёстких дисков, независимую от производителя.

В колонке Смещение можно определить величину смещения (положительное или отрицательное). Hard Disk Sentinel добавит (вычтет) это значение для атрибута при его оценке. Это может использоваться, например, во время процедуры калибровки температуры. Есть несколько вариантов установки величины смещения:

· Используя иконки - и + : уменьшение или увеличение значения на единицу.

· Нажимая на число между иконками: значение может быть определено непосредственно в маленьком окне.

· Если выбран правильный атрибут, то можно использовать кнопки +, ENTER и -, чтобы определить значение смещения.

Примечание: рекомендуется определять смещение, нажимая непосредственно на число или ENTER.

Чекбоксы в колонке ВКЛЮЧИТЬ используются для включения/отключения атрибута. Если атрибут отключён, то он не определяет значения здоровья и производительности. Изменения отключенных атрибутов не сохраняются в логе жёсткого диска. Из-за этого блокировка любого атрибута НЕ РЕКОМЕНДУЕТСЯ.

Внимание: при использовании опций Смещение и Включить, может быть неправильно или неточно отображено состояние жёсткого диска. Только опытные пользователи могут изменять любую из этих опций.

Примечание: изменения опций Смещение и Включить сохраняются только в зарегистрированной версии. Если используется незарегистрированная версия, то изменение этих опций автоматически отменяется при перезапуске приложения.

Текстовое описание (со значением и важностью атрибута) отображается как подсказка, если навести курсор на атрибут. После нажатия правой кнопкой мышки на таблице, отображается всплывающее меню с опциями копирования всей страницы в буфер обмена, отображения подсказок для атрибутов и преобразования данных в десятичный формат. Полный список известных атрибутов S.M.A.R.T. описан в приложении.

После копирования информации в буфер обмена, можно вставить её в текстовый файл, электронную почту или любой другой документ.

Атрибуты графика

Под таблицей показана графическая история выбранного в данный момент атрибута S.M.A.R.T. По этому графику можно исследовать, как изменился атрибут. Две конечных точки графика отражают измеренное значение атрибута (в день установки) и последнее значение (текущее). Все другие дни между этими двумя датами выбираются автоматически.

Около графика отображены флаги состояния атрибута, которых может быть несколько. Они указывают на основную цель атрибута и могут быть следующими:

· Критический: значение может серьёзно повлиять на состояние здоровья жёсткого диска (например, количество секторов, перемещенных в резервную область).

· Статический: значение не влияет непосредственно или косвенно на состояние (например, количество циклов включения).

· Производительность: значение может затронуть производительность или скорость (например, время работы, время подвода головки).

· Частота ошибок: обычно исправимые атрибуты, где значение не влияет непосредственно на здоровье жёсткого диска (например, частота ошибок подвода головки).

· Счётчик событий: значение счётчика, которое увеличивается, если встречаются некоторые события или проблемы (например, найден новый сбойный сектор).

· Самосохранение: значение атрибута находится под непрерывным мониторингом.

Виды графика атрибутов

Можно отобразить несколько различных видов значений. По умолчанию, отображаются исходные, независимые от производителя данные в выбранной Области данных. Режим по умолчанию может быть выбран в разделе конфигурации на вкладке расширенные опции. Различия между методами описаны здесь.

Отображение области данных

Эти значения увеличиваются в случае возникновения проблем, потому что они содержат их фактическое количество (например, число сбойных секторов) или событий. График идеален, если значения не увеличиваются.

Множество атрибутов (например, время работы, счётчик циклов включения, и т.д.) всегда увеличиваются. При этом происходит тенденция графика к увеличению для этих атрибутов, но это нормально. Для некоторых (особенно статических) атрибутов число может быть очень высоким, а затем снова упасть, это также нормально. График важен для критических атрибутов (например, перераспределения, счётчика сбойных секторов), где анализ предыдущих значений может показать проблемные дни или целый период в жизни диска.

Отображение специальных значений поставщика

Исследуя числа в столбце "Значение", можно проверить тенденцию зависимых от изготовителя значений. Они уменьшаются в случае возникновения проблем, пока не достигнут порогового значения для атрибута. Если атрибут важен и порог достигнут, то значит у жёсткого диска есть проблема в этом пункте S.M.A.R.T. и он должен быть немедленно заменён. В этом случае изготовители должны заменить диск в соответствии с условиями гарантии.

Тёмно-синяя линия соединяет реально измеренные величины. Внизу графика порог отображён жёлтой линией.

Если тенденция идёт к уменьшению, то линия, соединяющая последнее измеренное значение с пороговым, будет фиолетовой. Она проведена на основе предыдущих значений (синяя линия). Это указывает на предполагаемый отказ жёсткого диска в будущем, так как легко увидеть, что значение атрибута будет уменьшаться быстрее назначенной даты достижения порога.

Например, на изображении выше можно увидеть, что жёсткий диск первоначально был исследован 28 октября 2006 года. Тогда значение Перераспределённых секторов было равно 100. 9 ноября 2006 года это значение стало равным 95 (из-за множества Перераспределённых секторов значение изменилось от 100 до 95). Если эта тенденция сохранится, то атрибут достигнет своего порога (36) 31 марта 2007 года (это отображено на правой стороне графика). Таким образом, всё это легко увидеть и заранее предпринять соответствующие меры. Это означает, что до этой даты жёсткий диск должен быть заменён из-за увеличивающегося количества ошибок.

Различия между этими двумя методами описаны здесь.

Примечание: для жёстких дисков SCSI панель S.M.A.R.T. содержит статистическую информацию, предусмотренную этими дисками (например, всего байт чтения/записи, количество ошибок чтения/записи и т.п.). График под списком может быть использован, чтобы исследовать тенденцию любого такого атрибута.

Захватите мышью и перетащите линию между таблицей S.M.A.R.T. и графиком, чтобы изменить размеры панелей.


Èíôîðìàöèÿ

Информация

На информационной странице отображается множество подробностей жёсткого диска. Они включают в себя: изготовителя и тип модели, модификацию (встроенную версию), серийный номер жёсткого диска и т.д. Они могут использоваться для проверки и идентификации жёсткого диска.

Отображается логический диск(и), который связан с данным жёстким диском. Это может быть полезно, когда установлено несколько жёстких дисков и в системе получается несколько логических дисков.

Используя правую кнопку мыши, можно скопировать информацию, отображаемую в таблице, в буфер обмена. Позже её можно вставить в текстовый файл, электронную почту или любой документ.

IDE, Serial ATA жёсткий диск

Жёсткие диски интерфейсов IDE и Serial ATA управляются и идентифицируются через интерфейс ATA. Hard Disk Sentinel обнаруживает и отображает их физические характеристики (например, общее количество секторов, исправленных ошибочных байт и т.д.). Размер Буфера может быть важным, так как это размер внутренней кэш-памяти диска. Когда важна производительность, то рекомендуется использовать жёсткие диски с большими размерами буфера.

Отображаются максимальный и текущий режимы выбранного Ultra DMA. Последние теоретически определяют текущую максимальную скорость передачи данных между диском и компьютером. Конечно большее значение лучше.

Если выбран текущий режим Ultra DMA (0), то система не использует его для передачи и работает в режиме PIO (Программируемый контроллер ввода/вывода). Это значительно уменьшает производительность диска и всей системы в целом, потому что процессор должен ждать завершения каждой операции чтения/записи. Рекомендуется изучить конфигурацию и решить эту проблему (например, перестроив конфигурацию жёстких дисков и оптических устройств или используя новый кабель). Режим Ultra DMA 33 (2) означает, что используется старый IDE кабель с 40 проводками вместо более новых с 80. Поэтому не рекомендуется использовать круглые или длинные кабели.

Примечание: на некоторых контроллерах или системах возможно, что диск работает в режиме PIO, но предварительно был выбран режим Ultra DMA и это отображается в этом окне. Если Вы не уверены, но испытываете медленную производительность, проверьте текущие настройки в менеджере устройств, выбрав свойства (IDE) контроллера.

Примечание: Hard Disk Sentinel проверяет, закончена ли информационная таблица ATA, и правильность контрольной суммы этой таблицы. Последнее гарантирует, что обнаруженная информация отображается верно. Если это не так, то возможно, что о некоторых значениях жёсткий диск не может правильно сообщить (например, значение производительности, режим передачи UDMA и свойства интерфейса Serial ATA). Есть предупреждение, которое отображается в таких случаях:

Неверный Служебный Байт ATA или значение Контрольной Суммы ATA не затрагивают обнаружение и отображение здоровья и температурных значений.

Управление шумом

Здесь можно рассмотреть и изменить звуковые настройки, если эта функция поддерживается жёстким диском. Более высокие акустические уровни сделают операции быстрыми, но более шумными. Установка низкого уровня сделает работу диска медленной и тихой (позиционирование головки чтения/записи будет медленным и более тихим). Звуковая настройка не влияет на скорость вращения диска. Если диск поддерживает такие настройки, то можно изменить их уровень, нажав на кнопку Регулировка.

Отображаются самые важные характеристики ATA, а дополнительные функции будут просто отмечены (например, режим безопасности, управление питанием и т.д.).

Детали S.M.A.R.T.

Результаты и детали аппаратной самодиагностики жёсткого диска показаны в этом разделе. Поддерживаемые самодиагностики можно выполнить отсюда, нажав на пункт Запуск. Также здесь показано предполагаемое время самодиагностики (данные производителя), но она может занять намного больше времени до завершения, чем заявлено. Короткая самодиагностика проверяет функциональные возможности главных компонентов жёсткого диска (головки, сервомотора, электроники). Опции Расширенной самодиагностики и самодиагностики Передачи (если поддерживаются) выполняют определённые производителем тестовые шаги. Расширенная самодиагностика полностью проверяет поверхность жёсткого диска. Во время этой операции проверяются проблематичные области диска (если выбрано любой), таким образом мы рекомендуем периодически выполнять этот тест.

Во время теста показывается окно с текущим состоянием диска. После завершения теста, будет отображён результат об успешном его выполнении или неудачном, из-за проблем с сервомотором, электроникой, головкой и т.д. Во время самодиагностики жёсткий диск можно использовать. Обычно светодиод HDD во время тестов остаётся тёмным, но можно слышать шум работы жёсткого диска. Операции чтения/записи во время теста могут замедлить сам тест и наоборот, из-за теста операции чтения/записи могут занять гораздо больше времени, так что рекомендуется выполнять тест в неактивные периоды.

Примечание: Расширенная самодиагностика и самодиагностика Передачи (если поддерживаются) могут быть использованы только в зарегистрированной версии.

SCSI жёсткий диск

Для жёсткого диска SCSI показана информация, требуемая для его идентификации. Поставщик предусмотрел отображение строки состояния и функции прогноза отказа с обнаруженными исходными значениями ASC и ASCQ.


Óðîâíè øóìà

Уровни шума

Здесь можно рассмотреть и изменить акустические настройки жёсткого диска интерфейсов IDE/Serial ATA, если эта функция поддерживается диском. Настройка более высокого звукового уровня сделает операции быстрее, но работу диска громче. Установка же низкого уровня наоборот - медленнее, но тише (позиционирование головки чтения/записи будет медленным и более тихим). Акустическая настройка не оказывает никакого влияния на скорость вращения диска.

Используя бегунок, можно выбрать необходимую для себя настройку (медленную или быструю операцию, или равнозначное значение между конечными точками). Отображается рекомендуемый акустический уровень, определённый изготовителем. Настройка любого акустического уровня не будет затрагивать здоровье жёсткого диска.

Если два или более жёстких диска протестированы и сравнены (например, в эталонном тесте), то у всех дисков должен быть одинаково сконфигурированный акустический уровень (например, самый быстрый или самый медленный) для получения точных результатов.

Примечание: акустическая конфигурация уровня сильно зависит от характеристик компьютера (контроллера, материнской платы) и установленных драйверов. Если контроллер или драйвер не поддерживают эту функцию, то будет отображено сообщение об ошибке и акустический уровень останется неизменным. Мы надеемся, что всё больше производителей встроит эту характеристику в свои изделия.


Ëîã

Лог

Для каждого жёсткого диска, установленного в системе, Hard Disk Sentinel поддерживает лог (журнал). Данные об ухудшении состояния наиболее важных атрибутов S.M.A.R.T. сохраняются в этом логе. Это следующие атрибуты:

· 5: Reallocated Sectors Count (Счётчик Перемещённых Секторов).

· 10: Spin Retry Count (Счётчик Повторного Запуска Вращения).

· 196: Reallocation Event Count (Счётчик Операций Переназначения).

· 197: Current Pending Sector Count (Счётчик Нестабильных Секторов).

· 198: Off-Line Uncorrectable Sector Count (Счётчик Неисправимых Ошибок Чтения/Записи).

· 199: Ultra ATA CRC Error Count (Счётчик Ошибок Передачи Данных).

Если жёсткий диск не реагирует на запросы Hard Disk Sentinel в течение длительного периода, то это событие будет также зарегистрировано в логе (если эта функция включена на вкладке Расширенные Опции).

Все данные имеют точную дату и время, вспомогательный идентификатор, а также предшествующие и новые исходные значения атрибута. Возможно, что два или более атрибута изменились со времени последнего обнаружения (особенно если Hard Disk Sentinel запускается редко), значит, в таком случае, создаются две или более регистрационные записи в одно и то же время.

Можно настроить приложение так, что оно будет создавать и отправлять предупреждения, если в логе появится новая запись. В случае, если Hard Disk Sentinel обнаружит новую проблему (которая может изменить состояние диска), то это поможет предупредить пользователя. Эта характеристика доступна только в зарегистрированной версии.

Можно отключить некоторые атрибуты диска на странице S.M.A.R.T., используя опцию в колонке "Включить". Изменения отключенных атрибутов не будут сохраняться в лог (они не создадут предупреждение) и не повлияют на здоровье диска.

Примечание: Текущая версия лога сохраняет 50 записей о последних проблемах. При появлении новых записей более старые удаляются.


Ïðîèçâîäèòåëüíîñòü â ðåàëüíîì âðåìåíè

Производительность в реальном времени

На этой странице отображено количество переданных данных (чтение и записи) в текущей сессии и со времени установки диска. Используя это, также отображается и среднее ежедневное значение чтения/записи.

Hard Disk Sentinel непрерывно контролирует текущие скорости чтения/записи и нагрузку использования жёсткого диска. Это значение отображается в процентах (%) и пользователь может его рассмотреть так же, как использование CPU в менеджере задач.

Если Hard Disk Sentinel обнаруживает операцию записи, то отображается красный индикатор и текущая скорость записи. В случае обнаружения операции чтения, отображается скорость чтения и индикатор зелёного цвета. Эти цвета не зависят от состояния здоровья жёсткого диска.

Основываясь на текущих значениях скорости передачи и использования диска, приложение оценивает возможную (теоретическую) максимальную скорость передачи, которая может быть достигнута как пиковая за короткий промежуток времени. Это значение вычисляется по следующей формуле: (предполагаемая максимальная скорость передачи) = (текущая скорость передачи) / (текущее использование диска %). Например, если диск передаёт данные со скоростью 20 MБ/сек и текущее использование диска равно 50%, то предполагаемая максимальная скорость передачи будет равна 40 MБ/сек. Чтобы увеличить точность измерения, значения, вычисляемые при слабом использовании диска, автоматически игнорируются. Это теоретически максимальное значение, но некоторые устройства, кэши или другие приложения могут на него повлиять.

Текущая дисковая скорость передачи и графики использования диска могут быть полезными во многих случаях. Например:

· При использовании двух или нескольких жёстких дисков, можно исследовать, какие диски являются активными и какой скоростью они управляют. Например, если система установлена на первом жёстком диске, а на другом есть приложение, которое генерирует огромный трафик, то дисковое использование для этого приложения может быть легко проверено. Во время постоянной загрузки, текущее использование системного жёсткого диска можно также исследовать, обнаружив слишком большое использование виртуальной памяти.

· Во время копирования между двумя различными жёсткими дисками. Скорость передачи и скорость этих дисков могут быть сравнены, и будет видно, какой из дисков медленнее.

· Во время прожига данных на оптический носитель: чтобы проверить реальную скорость передачи данных (скорость прожига) и наибольшее значение использования диска. Понижение использования диска означает, что может быть выбрана более высокая скорость прожига.

· На сервере (файловом или баз данных с огромной загрузкой) возможно исследовать использование и скорость передачи диска(ов). Это поможет администратору решить, требуется ли новый (более быстрый) жёсткий диск в случае добавления новых клиентов.

· Если во время операции с постоянной скоростью (например, прожиг DVD) использование диска постоянно повышается и падает (график "скачет"), то данные на жёстком диске могут быть сильно фрагментированы, и рекомендуется повести дефрагментацию. (Также создать эту проблему может слишком интенсивное использование виртуальной памяти).

Примечание: мониторинг производительности в реальном времени зависит от текущей операционной системы. Это не доступно под Windows 95/98/ME. На некоторых внешних дисках (например, флэш-памяти или картах памяти) тоже не поддерживается эта функция.


Ïðåäóïðåæäåíèÿ

Предупреждения

На этой странице показаны предупреждения, сгенерированные жёстким диском.

Список содержит два типа событий: (перегрев, низкое здоровье, предсказанный отказ и т.д.) и дату события.

В этом списке отображены только те события, которые зарегистрированы и связаны хотя бы с одним предупреждением (звуковым, по электронной почте и т.д.).


Ëîãè÷åñêèé äèñê

Логический диск

На информационной панели отображены детали выбранного логического диска, включая связанный с ним физический жёсткий диск (в случае чередующегося или зеркального тома, логический диск может быть связан с несколькими физическими дисками). Показаны метка тома, название, серийный номер, тип устройства и раздела. Информация о заполненном и свободном пространстве также отображена в этом окне.


Êîíôèãóðàöèÿ

Конфигурация

При использовании этого окна можно изменить опции Hard Disk Sentinel. Опции упорядочены в различные категории, которые расположены с левой стороны окна. Нажатие на категорию отобразит соответствующие опции управления справа. Имеются следующие категории:

· Жёсткие Диски

· Предпочтения

· Окно Состояния

· Пороги / Иконки

· Предупреждения

· Настройки Отчёта

· Конфигурация E-mail

· Регистрация

· Обновление

· Расширенные Опции

· Управление Дисками

· Горячие Клавиши

· Операции (доступно только в версии PROFESSIONAL)

· Интеграция

· Отправка Отчёта


Æ¸ñòêèå Äèñêè

Конфигурация: Жёсткие Диски

На этой вкладке показаны все обнаруженные в системе жёсткие диски. Отметив чекбокс перед номером жёсткого диска, Вы установите, чтобы данный диск отображался в окне состояния. Двойной щелчок на любом жёстком диске добавит/удалит его иконку в системном трее.

Можно показать только одну иконку в трее с самой высокой температурой. Таким образом, иконку можно изменить, чтобы отобразить другие жёсткие диски (поскольку значения температуры могут меняться). Если эта опция включена и разрешён показ значка состояния, то будет отображаться символ диска с самым низким показателем здоровья (даже если значение самой высокой температуры у другого жёсткого диска).

Примечание: если указатель мыши переместить на иконку в системном трее, появится небольшое окно с информацией о деталях соответствующего жёсткого диска..

Нажатие правой кнопкой мыши на любом жёстком диске покажет локальное меню этого диска (смотрите изображение выше). Из этого меню можно показывать или скрывать иконку диска в системном трее или получить доступ к его деталям (любой информационной странице). Кроме того, из этого меню можно открыть окно управления шумом (если эта опция поддерживается жёстким диском).


Ïðåäïî÷òåíèÿ

Конфигурация: Предпочтения

Здесь можно управлять некоторыми глобальными опциями Hard Disk Sentinel.

Показывать окно состояния при запуске: окно состояния будет или не будет появляться автоматически при запуске приложения. Скрытие или показ окна состояния из главного окна программы, также изменят эту опцию (если окно было скрыто, а приложение перезапущено, то оно не будет автоматически отображено).

Загружать вместе с Windows: Hard Disk Sentinel будет запускаться каждый раз при загрузке Windows. Рекомендуют использовать эту функцию, так как в этом случае состояние жёстких дисков будет постоянно анализироваться.

Показывать главное окно при запуске: автоматический показ главного окна при запуске приложения.

Примечание: эту опцию можно отключить только в зарегистрированной версии. В противном случае, главное окно будет автоматически отображаться при запуске программы.

Показывать приложение на Панели Задач и в Системном Трее: если открыто любое окно Hard Disk Sentinel (кроме окна состояния), значок приложения отображается на панели задач, рядом с другими запущенными программами. Если эта опция отключена, то будут отображаться только иконки в системном трее около часов, даже если хотя бы одно из окон приложения открыто.

Здесь также можно выбрать язык интерфейса, который Вы хотите использовать во всех отчётах, электронной почте и сообщениях, отображение температуры (по Цельсию или Фаренгейту), единицу передачи данных в (MБ, ГБ или TБ), которая будет использоваться для определения производительности на странице информации для всех жёстких дисков и т.д.


Îêíî Ñîñòîÿíèÿ

Конфигурация: Окно Состояния

Схема размещения окна состояния может быть сконфигурирована на этой странице. Пользователь может выбрать любой цвет или изображение, чтобы использовать это как фон для окна состояния. Выбор можно сделать, используя соответствующую кнопку "Выбрать". Как предварительный просмотр, выбранный цвет или изображение отображается в верхнем правом углу.

Примечание:при использовании изображения как фона, оно будет автоматически растянуто до соответствующего размера окна состояния.

Если включить опцию "Залипать" к краям экрана, то окно состояния не может быть перемещено за пределы экрана. При попытке сделать это, окно будет автоматически выравниваться по границе экрана. Если эта опция отключена, окно может быть перемещено (частично или полностью) за пределы экрана.

Здесь также можно настроить прозрачность окна состояния (если это поддерживается операционной системой) и выбрать тип шрифта, размер и цвет. Рекомендуется использовать корректные настройки, чтобы пользователю было удобно читать текст (руководствуясь его предпочтениями освещённости и контраста), но размер окна не должен мешать в работе.

При включении опции не реагировать окну состояния на действия мыши, это окно не будет отвечать на щелчки мыши и попытки его перетаскивания. Лучше объединить эту опцию с опцией прозрачности фона - таким образом, появится возможно нажать на окно, находящееся под окном состояния.

Примечание: если эта опция включена, то окно состояния не может быть выбрано или перемещено. Можно воспользоваться иконкой в системном трее, чтобы обратиться к функциям приложения.

Всю информацию из окна состояния можно отобразить непосредственно на рабочем столе. Данные отображаются под всеми другими окнами и их можно увидеть, выбрав опцию отображать на рабочем столе. Используя координаты X и Y, можно настроить местоположение информации.

Примечание: информация отображается поверх ярлыков и иконок рабочего стола, так что рекомендуется определить для неё свободную область. Для использования этой функции, опции "активный рабочий стол" и "отображение вебстраницы" должны быть отключены.

Примечание: эта функция может интенсивно использовать ресурсы процессора, поэтому мы не рекомендуем использовать её на медленных компьютерах.

Используя опцию Полностью прозрачный фон, можно установить фон окна состояния полностью прозрачным, чтобы под ним стали видимы иконки с надписями. Если эта опция включена, окно состояния нельзя спрятать щелчком мыши, но можно использовать горячие клавиши для его показа/скрытия.

Есть целый список возможных пунктов для их отображения в окне состояния.

Примечание: сконфигурированные пункты также отобразятся во всплывающей подсказке, если навести курсор мыши на иконку в системном трее.

В Windows Vista или Windows 7 можно использовать специальный гаджет, чтобы отобразить информацию о жёстком диске (например, температуру и здоровье). Визуальное отображение гаджета (цвет, шрифт, жёсткие диски) можно установить в настройках окна состояния.


Ïîðîãè / Èêîíêè

Конфигурация: Пороги / Иконки

На этой вкладке можно установить визуальное отображение иконки в системном трее. По умолчанию, иконка отображает текущую температуру жёсткого диска и символ здоровья: который изменяется, если значение здоровья находится около установленного порога.

Цвета возможно настроить тремя различными шагами: установить передний план и цвет фона для низкой температуры (зелёный уровень), высокой температуры (красный уровень) и температуры между низкой и высокой (жёлтый уровень). Пороговые значения можно также определить на этой вкладке. Любой фон или цвет переднего плана можно сделать прозрачным. Для этого в диалоге "Определить цвет" укажите следующие значения: RED=254, GREEN=254, BLUE=255. Тогда цвет окна состояния и иконки в системном трее будет прозрачным.

Возможно также показать символ здоровья диска на иконке в системном трее. Это может быть [image] (отличное, в случае высокого значения здоровья), [image] (плохое, в случае низкого состояния) или [image] (удовлетворительное, между этими двумя порогами). Можно выбрать, когда будет отображаться символ здоровья - например, показать только тогда, когда здоровье слишком низкое.

Если включён показ температуры и символа здоровья, то эти два изображения будут отображаться чередуясь через одну секунду. Это "мигание" может привлечь внимание пользователя, но может и мешать. Рекомендуется сохранить настройки по умолчанию: высвечивать изображение в системном трее только в случае возникновения проблемы.


Ïðåäóïðåæäåíèÿ

Конфигурация: Предупреждения

Одной из самых важных характеристик Hard Disk Sentinel является возможность сделать предупреждение или выполнить определённые задачи в случае обнаружения проблемы. Таким образом, проблем можно избежать и, при использовании автоматических задач, создать архивную копию файлов для предотвращения потери данных. Множество различных задач могут быть связаны с любой из проблем.

При ожидании отказа: это происходит с жёстким диском, если какой-нибудь критический параметр S.M.A.R.T превысил порог, определённый производителем. В этот момент жёсткий диск должен быть немедленно заменён.

Примечание: в это время, здоровье жёсткого диска уже приближается к 0%.

Примечание: эта функция доступна только в зарегистрированной версии.

Когда состояние диска низкое: этот происходит с жёстким диском, если значение здоровья ниже настроенного жёлтого или красного уровней.

Примечание: эта функция доступна только в зарегистрированной версии. В незарегистрированной версии можно выбрать только жёлтый уровень для получения предупреждений.

Когда температура высокая: это происходит с жёстким диском, если температура превышает настроенного жёлтого или красного уровней.

Примечание: эта функция доступна только в зарегистрированной версии. В незарегистрированной версии можно выбрать только жёлтый уровень для получения предупреждений.

Когда появляется новая запись в логе: это происходит с жёстким диском, если критический атрибут S.M.A.R.T. ухудшается и тогда эта проблема регистрируется в логе жёсткого диска.

Примечание: эта функция доступна только в зарегистрированной версии.

Когда свободного места на диске мало: это происходит с логическим диском, если размер свободного места становится меньше настроенного порога.

Примечание: эта функция доступна только в зарегистрированной версии. Можно сконфигурировать порог свободного дискового пространства глобально (одна настройка для всех логических дисков) или же установить разные пороги для каждого диска отдельно (используя % или мегабайты, как единицу измерения):

Здесь можно выбрать опцию звуковое предупреждение. Это может быть любой звуковой файл, поддерживаемый системой (например, wav, mid, mp3, wma). Hard Disk Sentinel будет использовать этот файл в качестве предупреждения.

Если включена опция Повтор звукового сигнала, то приложение будет повторять звуковое предупреждение до тех пор, пока пользователь не подтвердит его получение , отключив это предупреждение (из меню быстрого доступа или главного окна). Таким образом, будет отображена причина предупреждения и пользователь сможет исследовать её прежде, чем захочет его отключить. Использование этой функции рекомендуется на серверах, где нет локального пользователя, а удалённое предупреждение невозможно, но люди могут обратить внимание на звуковое предупреждение.

Опция Использовать PC speaker позволяет задействовать внутренний зуммер компьютера вместо звуковой карты. При этом нет необходимости подключать внешние динамики к компьютеру. Использование этой функции рекомендуется на серверах (объединив с предыдущей опцией).

Примечание: если эта функция будет включена, то звуковое предупреждение будет звучать как двойной сигнал на 1000 Гц, вместо запуска звукового файла на PC speaker.

Примечание: некоторые компьютеры (особенно ноутбуки) не имеют встроенного зуммера, поэтому убедитесь, что он присутствует в вашей системе.

При использовании кнопки Тест Звукового Сигнала, можно проверить звуковое предупреждение (проиграть звуковой файл или использовать зуммер компьютера). Если сигнала не слышно, то необходимо проверить кабели, динамики или изменить конфигурацию.

Возможно послать запланированное сообщение на электронную почту, которое содержит текущую конфигурацию и состояние всех жёстких дисков. Hard Disk Sentinel автоматически отправит электронную почту позже, если её нельзя послать во время создания из-за отключения компьютера или сетевых проблем.

Примечание: эта функция доступна только в зарегистрированной версии.

Если опция Отправить сообщение будет использоваться для какой-нибудь проблемы, то сообщение будет показано и/или доставлено согласно установленным настройкам.

Если опция Резервная копия включена, назначенные задачи будут автоматически выполнены при обнаруженных проблемах. Можно назначить различные задачи, основываясь на проблемах жёсткого диска.

Примечание: Эта функция доступна только в версии PROFESSIONAL.

Если опция Отключить разрешена, то компьютер будет автоматически выключен, чтобы предотвратить дальнейшие проблемы. Конечно, приложение подождёт завершения всех других задач перед отключением компьютера. Будет показан небольшой обратный отсчёт перед завершением работы, что необходимо для отмены этого действия.

Важно: в каждой сессии, любая проблема на жёстких дисках может инициализировать предупреждение только один раз. Другими словами, если температура жёсткого диска достигнет жёлтого уровня и предупреждение настроено для этого уровня, то оно будет выполнено (например, проиграно звуковое предупреждение или отправлена почта и т.д.). Если жёсткий диск охладится ниже порога, а затем опять нагреется до жёлтого уровня, то предупреждение создано снова не будет. Таким образом, это поможет избежать получения слишком большого количества предупреждений, если состояние жёсткого диска находится около пороговых уровней. Конечно, если другой жёсткий диск нагреется до жёлтого уровня, то будет сгенерировано новое предупреждение.

Список ранее обработанных предупреждений очищается каждый день в полночь. Это означает, что компьютер (сервер), работающий в течение длительного времени (неделю или более), может создать единственное предупреждение об одной проблеме для жёсткого диска каждый день.

Список ранее обработанных предупреждений можно очистить в любое время из главного окна.


Íàñòðîéêè Îò÷¸òà

Конфигурация: Настройки Отчёта

Если обнаруживается проблема, Hard Disk Sentinel может отправить или показать предупреждение. На этой странице находится настройка типов таких предупреждений. Возможна любая комбинация вариантов.

Примечание: по крайней мере хотя бы один тип предупреждений должен быть выбран.

Отправлять на Е-mail: в случае возникновения проблемы, Hard Disk Sentinel отправит электронную почту с описанием проблемы. Почта будет доставлена согласно настройкам на вкладке конфигурации e-mail. Перед отправкой можно выбрать интернет-соединение по умолчанию (это может быть необходимо, если используется dial-up или DSL модем), а также разорвать связь после отправки сообщения.

Примечание: если использовать опцию закрытия соединения, но связь уже была установлена перед отправлением почты (компьютер уже был соединён), связь разорвана не будет.

Пользователь может выбрать тип электронной почты. Это может быть полный отчёт HTML (включая изображения, но меньше 50 килобайт для одного жёсткого диска), полный текстовый отчёт (только простой текст) или краткое текстовое сообщение. Последнее является очень маленьким и быстрым, это полезно, если сообщение нужно доставить по электронной почте -> SMS шлюз.

Примечание: выбранный тип сообщения будет отправлен подобно отправке ежедневного состояния на e-mail. Также выбранный тип (HTML или текстовый) будет сохранён или отправлен, если пользователь нажмёт соответствующую кнопку в главном окне.

Можно настроить элементы, которые будут включены в подробном текстовом или HTML отчёте (при использовании зарегистрированной версии).

Примечание: независимо от настроенных элементов сообщение XML содержит все разделы.

Отправить на удалённый компьютер: Предупреждение можно отправить на любой компьютер в сети (аналогично использованию команды NET SEND). Чтобы послать и получить такие сообщения, сервис сообщений должна быть запущен на компьютерах отправителя и получателя. При использовании кнопки Выбрать можно определить компьютер получателя из локальной сети. Это может быть медленно в больших сетях и быстро, если определено непосредственное сетевое имя (без \\ префикса). Также, возможно отправить тестовое сообщение на удалённый компьютер, чтобы проверить подключение.

Важно: если удалённый компьютер не доступен (не отвечает из-за сетевой ошибки или сбоя питания), Hard Disk Sentinel автоматически снова отправляет сообщение через каждые 5 минут до успешной доставки (в текущей сессии). Если пользователь перезапустит программу, она опять повторит процедуру до её завершения.

Примечание: служба сообщений поддерживает только небольшие сообщения (до 254 символов). Обычно этой информации хватает только для описания проблемы и компьютера отправителя. В таких случаях администратор должен исследовать этот компьютер на наличие проблем. Рекомендуется сначала проверить файл HDS_problem_log.txt в папке Hard Disk Sentinel, потому что в нём есть информация о предыдущих предупреждениях. Возможно, что некоторые символы (не стандарта ASCII) отображены неправильно в доставленном сообщении.

Показывать сообщение на экране: при использовании этой опции сообщение будет отображаться на экране. Дополнительно, частное сообщение может быть отображено перед описанием проблемы. Hard Disk Sentinel читает это сообщение из текстового файла прежде, чем отобразить предупреждение. Это рекомендуется на компьютерах, которые не подключены к сети, и удалённые методы отправки не возможны. Например, частное сообщение может быть таким: "Пожалуйста, вызовите администратора по телефону XX-XXXXX-XXX и сообщите ему следующую информацию:".

Примечание: отправка ежедневного состояния на e-mail может быть совершена только по электронной почте, независимо от выбранного типа сообщения на этой вкладке.


Êîíôèãóðàöèÿ E-mail

Конфигурация: Конфигурация E-mail

На этой вкладке пользователь может создать настройки для доставки сообщений по e-mail. Необходимые настройки:

· Имя отправителя: это будет показано в поле отправитель (например, название компьютера пользователя).

· E-mail отправителя : e-mail адрес отправителя (например, адрес электронной почты пользователя компьютера).

· SMTP сервер: имя или IP адрес используемого сервера SMTP.

· E-mail получателя: e-mail адрес получателя, который прочитает сообщения о проблемах/состоянии (например, администратор). Возможно ввести два или больше адресов, разделённые запятой.

· Порт: если сервер SMTP не использует стандартный порт (25), то это можно определить здесь.

· Имя пользователя, Пароль: если требуется установление подлинности для отправки e-mail (этого требуют многие Провайдеры услуг интернета), то эта информация может быть введена здесь. Если необходимости в подтверждении нет, оставьте эти поля пустыми.

В поле Учётная запись можно выбрать заранее настроенную учётную запись почты Outlook или Outlook Express. Если учётная запись будет выбрана, то поля с именем отправителя, e-mail адресом, сервером SMTP и именем пользователя (если нужно) будут автоматически заполнены, согласно настройкам почтового аккаунта. Таким образом, если нужна аутентификация, то потребуется только адрес электронной почты получателя и пароль (из соображений безопасности поле пароля автоматически не заполняется).

Примечание: возможно, что показаны не все существующие учётные записи.

Примечание: после установки всех настроек, рекомендуется использовать кнопку Проверка почты, чтобы проверить конфигурацию или показать возможные проблемы с доставкой e-mail.


Ðåãèñòðàöèÿ

Конфигурация: Регистрация

После покупки зарегистрированной версии, регистрационный код автоматически доставляется пользователю. На этой вкладке необходимо ввести полученный код для регистрации и активации Hard Disk Sentinel, чтобы разблокировать все функции приложения.

Примечание: основная лицензия доступна для только для базовой версии, она не сможет активировать версию PRO. Напротив, с регистрационным кодом PRO, можно использовать все характеристики базовой версии и версии PRO.

Пользователь должен выбрать и ввести имя пользователя. Оно может быть любым: реальным именем, прозвищем, названием его компании и т.д. Это имя отображается в окне О Программе, как имя зарегистрированного пользователя. Позже его можно изменить в любое время, снова введя регистрационный код и нажав любую из кнопок "Регистрация". Поскольку приложение уже активировано, нет необходимости для любой сетевой связи или передаче файла.

Hard Disk Sentinel сначала сам проверяет регистрационный код, а затем код проверяется на регистрационном сервере (эта процедура называется активацией). Приложение регистрируется и активируется, если код принят и приложением и сетевым сервером. Это помогает предотвращать пиратское использование Hard Disk Sentinel.

Если компьютер подключен к интернету, то рекомендуется использовать метод активации онлайн. Для этого нажмите кнопку Регистрация и Активация Онлайн и введите регистрационный код после имени пользователя. Активация потребует нескольких секунд, даже если у вас низкая пропускная способность канала связи.

Если сетевой метод активации не возможен,то выберите опцию Регистрация и Активация через E-mail (после того, как введёте имя пользователя и регистрационный код). Hard Disk Sentinel создаст файл, который пользователь должен отправить, с полученным регистрационным кодом, (с другого компьютера) по адресу: info@hdsentinel.hu. Мы вышлем назад активированный файл ключа, который должен быть скопирован в папку установки Hard Disk Sentinel. После перезапуска приложения все опции станут доступными.

Примечание: если ваш регистрационный код не поддерживается нашей компанией (неверный) и активация онлайн выдаёт ошибку, пожалуйста, не пробуйте метод активации через e-mail. Запросы с неправильным регистрационным кодом (или вообще без него) будут автоматически удаляться.

Примечание: если пользователь должен переустановить операционную систему, Hard Disk Sentinel может быть повторно установлен и активирован столько раз, скольку пользователь пожелает, если первичный (primary) установленный жёсткий диск один и тот же во всех случаях. Если же этот жёсткий диск должен быть заменён, то количество активаций уменьшится на одно. Тогда для этого (нового) жёсткого диска пользователь сможет переустанавливать и активировать программу столько, сколько захочет. Hard Disk Sentinel может быть связан с 5 (пятью) разными первичными жёсткими дисками (если Вы должны заменить первичный жёсткий диск 6-ой раз, то свяжитесь с нами для продления вашей лицензии). Вторые, третьи и последующие диски или другие компоненты не оказывают никакого влияния на регистрационное состояние приложения. Пользователь может свободно добавить/удалить/заменить любой 2-ой или последующие жёсткие диски.

Если на одном компьютере установлено несколько операционных систем, Hard Disk Sentinel может быть установлен, зарегистрирован и активирован под всеми этими системами.

Примечание: использование КОРПОРАТИВНОЙ версии сделает эту вкладку конфигурации неактивной. Будет невозможно изменить имя пользователя или нажать на любую кнопку "Регистрации", поскольку приложение автоматически регистрируется и активируется сразу после завершения инсталляции.

Если срок установленной лицензии подходит к концу, дата срока истечения отображается в этом окне. Пожалуйста, свяжитесь с автором для продления вашей лицензии в случае её завершения.


Îáíîâëåíèå

Конфигурация: Обновление

Hard Disk Sentinel может обновить себя с сервера, если есть доступная новая версия. Пользователь может использовать функцию автоматического (еженедельного) обновления, или нажать кнопку Проверить новую версию сейчас для проверки доступности новой версии и автоматической её загрузки. Дата последней проверки новой версии отображается.

Во время обновления (и проверки новой версии) приложение будет закрыто. Иконка в системном трее, окно состояния и все другие открытые окна программы закроются во время работы модуля обновления, проверки последней версии и её загрузки, если доступная версия более новая, чем установленная:

Примечание: при регистрации и активации версии PROFESSIONAL этот модуль запускается, чтобы загрузить модуль архиватора. Позже, этот модуль также обновляется, поскольку приложение уже зарегистрировано.

Примечание: после успешного обновления запускается новая версия. Список предварительно обработанных предупреждений очищается, так что любые сконфигурированные предупреждения можно отправить снова.

Примечание: модуль обновления загружает только самую последнюю финальную версию (не бету). Оценочные бета-версии должны быть загружены и установлены вручную.

Примечание: зарегистрированные пользователи могут бесплатно обновляться до более новых версий и приложение останется зарегистрированным (если введён правильный регистрационный код) после процесса обновления.

Возможно резервировать и восстанавливать текущую конфигурацию приложения. Резервная копия сохраняет текущую конфигурацию, включая все опции и проекты, предыдущую статистику, файлы регистрации и регистрационные данные (зарегистрированного пользователя и файл активации). Таким образом, после повторной установки приложения, потребуется только восстановить предыдущую конфигурацию - программа будет автоматически зарегистрирована и все предыдущие настройки и статистика останутся прежними. Рекомендуется периодически делать резервную копию конфигурации и статистических данных на сменные носители, которые можно будет использовать в случае повторной установки программы.

Примечание: если конфигурация аппаратных средств изменяется, то, возможно, потребуется повторная активация программы.

Примечание: опция резервной конфигурации доступна только в зарегистрированной версии.


Ðàñøèðåííûå Îïöèè

Конфигурация: Расширенные Опции

Рекомендуем применять эти опции только опытными пользователям, поскольку они могут вызвать неправильную или несоответствующую системную операцию.

Частота опроса: время между двумя последовательными обнаружениями информации жёсткого диска (считывание информации S.M.A.R.T. для отображения температуры, здоровья и т.д). По умолчанию, Hard Disk Sentinel обнаруживает такую информацию каждые 5 минут. Большое количество жёстких дисков или медленных устройств могут уменьшить производительность приложения и увеличить время ответа. В этом случае рекомендуется перетащить ползунок вправо, чтобы считывание происходило чаще.

Примечание: очень частые обнаружения (раз в 1 или 5 секунд) могут уменьшить производительность.

Метод вычисления состояния: пользователь может выбрать метод для вычисления здоровья и производительности жёстких дисков. Рекомендуется использовать опцию "Анализ области данных" или опцию более строгого анализа, чтобы улучшить безопасность данных. Строгий метод рекомендуется на серверах, ноутбуках или компьютерах с интенсивным использованием диска или чрезвычайно важной информацией.

Включить предупреждение, если жёсткий диск не отвечает: если жёсткий диск не отвечает на запросы Hard Disk Sentinel, то будет создана запись в логе (которая может привести к предупреждению, если это разрешено). На вкладке Информация о диске будет отображена метка жёлтого, а затем красного цвета с обнаруженной проблемой. Использование этой опции не рекомендуется во всех случаях, если только это действительно необходимо (например, под Windows 98/ME).

Отключить автосканирование диска: используя эту опцию, можно отключить процедуру автоматической проверки диска, которая начинается вместе с запуском Windows. Это поможет предотвратить повреждение головки из-за неправильного обращения, а также повреждения устойчивых дисковых областей.

Задержка перед сканированием: если автоматическая проверка диска разрешена, то можно настроить необходимое время ожидание системы перед запуском этой процедуры. В это время, пользователь сможет отменить проверку диска, нажав любую клавишу.

Синхронизировать время компьютера с атомными часами: часы компьютера будут синхронизированы с удалённым сервером времени, используя протокол NTP (Сетевой протокол времени), чтобы отображать правильную дату и время. Это полезно для определения точной даты и времени любых предупреждений. Использование этой опции рекомендуется, если установлена версия PROFESSIONAL и настроены запуски запланированных проектов резервного копирования.

Примечание: если используется незарегистрированная версия, то эта опция будет автоматически заблокирована после первой синхронизации времени.

Создать и обновить XML файл: если разрешено, то детальная информация о жёстком диске автоматически заносится в специальный XML файл, который позже можно обработать в другой программе. По умолчанию, используется файл HDSentinel.xml, но это можно изменить, если нажать кнопку Выбрать. Предыдущий файл XML сохраняется, как резервная копия с расширением .BAK .

Примечание: эта функция доступна только в зарегистрированной версии.


Óïðàâëåíèå Äèñêàìè

Конфигурация: Управление Дисками

Hard Disk Sentinel непрерывно контролирует используемое и свободное место логических дисков (разделов). Эту информацию можно отобразить на иконках диска. Кроме того, значок с соответствующим текущим состоянием здоровья диска будет также отображён на его иконках.

Изменить иконки жёсткого диска по умолчанию: этой опцией можно глобально включить/отключить использование расширенных иконок жёсткого диска. Если опция заблокирована, то для диска используются системные иконки Windows. Если опция включена, используются расширенные иконки с отображением количества используемого места и значков здоровья. Эти иконки отображаются во всех приложениях, включая Проводник Windows.

Контролировать свободное место на сетевых дисках: также возможно исследовать информацию о свободном месте на удалённых дисках и автоматически обновлять эту информацию на панели главного окна.

Изменить системную иконку для сетевых дисков: после обнаружения, иконка сетевых (удалённых) дисков отобразит количество используемого места.

Контролировать свободное место на съёмных дисках: также можно исследовать информацию о свободном месте на съёмных дисках (например, флэш-памяти, внешних жёстких дисках, картах памяти) и автоматически обновлять эту информацию на панели главного окна.

Изменить системную иконку для съёмных дисков: после обнаружения, иконка съёмных дисков отобразит количество используемого места на них.

Примечание: на удалённых и большинстве съёмных дисках не возможно обнаружить информацию S.M.A.R.T. Таким образом, иконка отображает только информацию об используемом и свободном месте, но не состояние здоровья.

Примечание: проверка места на удалённых и съёмных дисках может быть очень медленной (особенно, если сетевой диск недоступен или если в устройство чтения карт не вставлена карта). Рекомендуется использовать эти опции, только если они не уменьшают производительность системы и приложения.

Можно определить, какие диски должны быть исключены из проверки дискового пространства, а какие должны сохранить дисковую иконку, заданную по умолчанию. Пожалуйста, перечислите буквы дисков (без двоеточия и пробелов) в соответствующем поле.

Примечание: Hard Disk Sentinel может обнаружить и изменить иконки только если запущен. При закрытом приложении, отображаются предыдущие иконки диска (системные иконки или изменённые, если стороннее приложение изменило их раньше).

Примечание: некоторые операционные системы (например Windows XP SP1) не могут правильно отобразить иконки жёсткого диска. Пожалуйста, установите самый последний пакет обновления, если столкнулись с этой проблемой.

Опция Выбор иконки диска используется для определения типа иконки жёсткого диска (XP или Vista), которая будет отображаться в Проводнике Windows. Иконки показывают состояние здоровья жёсткого диска и количество используемого места.


Ãîðÿ÷èå Êëàâèøè

Конфигурация: Горячие Клавиши

Можно обратиться к некоторым функциям Hard Disk Sentinel, используя горячие клавиши. Это системные горячие клавиши, и они работают, даже если другое приложение выбрано и запущено (кроме некоторых приложений, например игры, которые могут блокировать их использование).

Самые полезные опции, к которым можно обратиться посредством горячих клавиш, это показ/скрытие окна состояния, отображение главного окна или окна конфигурации.

Горячие клавиши доступны только в зарегистрированной версии.

Примечание: есть комбинации горячих клавиш, которые не работают под некоторыми операционными системами. Например, Vista может блокировать комбинацию CTRL+ALT+Fx.


Îïåðàöèè

Конфигурация: Операции

Hard Disk Sentinel PROFESSIONAL в состоянии автоматически делать операции резервного копирования, их планировку и выполнение после сбоя. Эта характеристика описана в следующих главах:

· Проекты

· Планировка

· Резервная копия


Ïðîåêòû

Конфигурация: Операции, Проекты

Эта функция доступна только в версии PROFESSIONAL.

При использовании Hard Disk Sentinel версии PRO возможно определить различные задачи (проекты) и наметить их регулярное выполнение. Определённые проекты могут быть выполнены в результате некоторых событий, например в случае низкого значения здоровья диска. Можно выполнить два или более различных проекта в одно и то же время или последовательно (запускать очередной проект после завершения другого). Обычно проекты являются операциями архивирования данных, но также можно определить и другие виды проектов.

Сначала требуется короткое имя для проекта резервного копирования (позже его нельзя изменить). Нажав кнопку Новый, пользователь может ввести это имя, после чего отобразятся детали проекта, но пока с пустыми областями.

Используя кнопку Удалить, выбранный проект может быть удалён из списка проектов, если он больше не нужен.

Примечание: если проект был связан с одной или более датами или событиями, то пользователь должен подтвердить операцию удаления. Пожалуйста, будьте осторожны при удалении проекта, который последовательно связан с другим проектом.

Пользователь может ввести своё описание о реальной функции проекта в область Комментарий. Если проект будет нуждаться в подтверждении перед выполнением, то имя и этот комментарий будут показаны, чтобы можно было решить, запускать проект или отменить это действие.

Проекты могут быть следующих типов:

· Запустить внешнее приложение: проект запустит указанное внешнее приложение, внутреннюю команду (например, COPY) или пакетный (BAT) файл. Можно использовать например, сжатие папок с выбранным архиватором и/или прожиг файлов на оптический диск, используя командную строку программы для создания CD/DVD. Также можно использовать проект для запуска любого другого приложения например, чтобы обновить базу данных антивирусного приложения. Для этого должно быть определено приложение со всеми параметрами командной строки. Приложение можно выбрать при помощи кнопки Обзор. Имя и путь к приложению должны быть определены между кавычками ("), если это имя или путь к нему содержат пробелы. Дополнительные параметры можно указать после последней кавычки имени приложения. Например: "C:\Program Files\MyProg Folder\MyProg.exe" parameter1 parameter2

Если пользователь выберет опцию Запустить в фоне, не отображая окно, то приложение будет работать в фоновом режиме без отображения своего окна.

При включённой опции Тревога при ошибке будет сгенерировано предупреждение (согласно Настройкам сообщений), если внешнее приложение или BAT файл возвратится с кодом завершения отличным от 0.

Примечание: используя BAT файл, с помощью функции EXIT xx можно определить код завершения. Если BAT файл содержит if .. then операторы, то это поможет определить правильные коды завершения в различных пунктах BAT файла. Правильный (беспроблемный) код завершения является 0, любой другой код сделает предупреждение с возвращённым кодом завершения (если эта опция разрешена). В этом случае, никакие другие проекты, находящиеся в зависимости от этого проблематичного проекта, запущены не будут.

· Передача файлов и папок: в этом случае используется внутренний модуль архивации для архивирования файлов. При использовании этого модуля, можно настроить различные варианты архивации и создать определённые задачи резервного копирования. Нажав кнопку Настроить, пользователь может определить опции проекта архивирования.

Примечание: эта функция доступна только в зарегистрированной версии.

· Запись CD/DVD используя NERO: Hard Disk Sentinel будет использовать приложение NERO (ТМ) от Ahead Software AG, чтобы архивировать содержание любой указанной папки на оптический диск.

Здесь можно определить расположение файла NEROCMD.EXE (версия командной строки для NERO), используя кнопку Выбор приложения. Если это не определено, но проект сконфигурирован, Hard Disk Sentinel запросит настроить отсутствующую позицию приложения.

Командная строка, которая будет выполняться, может быть c проверкой всех параметров. Нажав CTRL+C, можно скопировать содержание этого окна в буфер обмена.

Необходимо обязательно определить исходную папку. Её имя может содержать переменные (например, %USER %, %LAST % и т.д), подробно они описаны в настройках папки. Если будет использоваться новая папка %LAST % (созданная с использованием даты и времени) в указанной папке ( L:\BACKUP в нашем случае), то она будет являться исходной папкой. Это нужно использовать, если другой проект предварительно сохранил данные в L:\BACKUP и опции Использовать текущую дату как имя папки и сохранять последние XX полных архива разрешены для этого проекта.

Также обязательно выбрать дисковод для прожига (если есть несколько CD/DVD приводов, установленных на компьютере), установить скорость записи и тип диска (CD или DVD). Скорость будет автоматически откорректирована согласно свойствам привода и вставленных носителей. Опции защиты от опустошения буфера (BURN) и проверки данных после записи можно разрешить или заблокировать.

Можно определить различные параметры командной строки. Они будут отправлены на NEROCMD.EXE. Например, параметр - disable_eject - отключает функцию извлечения диска. Полный список параметров можно посмотреть, используя команду NEROCMD/?.

Можно запустить процесс прожига в фоновом режиме (не отображая никакого окна) и включить опцию обработки ошибок для проектов типа Запустить внешнее приложение. Пожалуйста, проверьте руководство пользователя NEROCMD, чтобы изучить весь список возможных кодов завершения NEROCMD.

Примечание: эта функция доступна только в зарегистрированной версии.

· Сжимать файлы, используя RAR/7-Zip: Hard Disk Sentinel может использовать приложения WINRAR (TM) из RarSoft или бесплатный 7-Zip, как архиваторы. Список доступных опций одинаков для обеих программ.

Примечание: более старые версии 7-Zip не поддерживают создание многотомных архивов.

Здесь необходимо определить расположение файлов RAR.EXE или 7Z.EXE (командная строка архиватора), используя кнопку Выбор Приложения. Если это не будет определено, но проект уже сконфигурирован, то Hard Disk Sentinelа сделает запрос о расположении недостающего приложения.

Командная строка, которая будет выполнена, может быть проверена со всеми параметрами. Нажав CTRL+C, можно скопировать информацию из этого окна в буфер обмена.

Чтобы сжать архив, нужно определить исходную папку. Она может содержать переменные (например, %USER %, %LAST %, а детали переменных описаны в настройках папки).

Также обязательно определить конечный файл, чтобы сохранить сжатый архив. Есть опция, чтобы создать многотомный архив и настроить размер тома в килобайтах (1024 байта).

Можно определить различные параметры командной строки при запуске приложений RAR или 7Z. Это могут быть следующие параметры: -mXXX - для определения метода сжатия, -pXXX - для определения пароля или -sfx - для создания самораспаковывающегося архива. Полный список параметров может быть отображён при использовании команды WINRAR/? или 7Z (без параметров)

Можно запустить процесс сжатия в фоном режиме (без отображения окна) и разрешить опцию обработки ошибок для проектов типа Запустить внешнее приложение. Пожалуйста, проверьте руководство пользователя WINRAR или 7-Zip для изучения полного списка возможных кодов завершения приложения.

Примечание: эта функция доступна только в зарегистрированной версии.

· Экспорт пунктов реестра: указанные ключи реестра экспортируются в файл, имя которого может содержать переменные.

Примечание: эта функция доступна только в зарегистрированной версии.

· Включение компьютера: Можно включить удалённый компьютер в локальной сети, отправив пакет запуска на целевой компьютер. Для этого необходимо определить MAC адрес целевого компьютера (это нужно, чтобы его найти, например, для сообщения от Hard Disk Sentinel на целевой компьютер). Дополнительно программное обеспечение может ждать, пока компьютер не будет готов (ответит на PING), но не больше указанного времени. Рекомендуется проверить защиту системы, компьютер (инициализация в сети (wake-on-lan) должна быть разрешена) и конфигурацию сети.

Примечание: эта функция доступна только в зарегистрированной версии.

· Выключение компьютера: Локальный или удалённый компьютер может быть выключён или перезагружен. Также локальный компьютер можно отправить в режим ожидания или гибернацию.

Примечание: эта функция доступна только в зарегистрированной версии.

· Отправка файлов на e-mail: С помощью этой функции можно передать по электронной почте файлы или папки со всеми включёнными файлами и подпапками. После выбора соответствующего типа, файлы или папки должны быть определены и разделены точкой с запятой (;). На вкладке конфигурации e-mail можно заполнить соответствующие поля (отправитель, почтовый сервер) и выбрать опции аутентификации.

Можно отправить все файлы по отдельным электронным адресам. Эта опция идеальна, если отправлять отдельный файл (архив), который не являются слишком большим для передачи по электронной почте. Для большого количества небольших файлов можно собрать их вместе, пока не будет достигнут минимальный предел и отправить их. Таким образом, все письма будут состоять из, скажем, 2000 килобайт данных каждое, кроме последнего, которое будет содержать оставшиеся файлы. Перед использованием этой опции рекомендуется проверить размер данных и доступность места на почтовом сервере, что обеспечивается провайдером сети.

Примечание: эта функция доступна только в зарегистрированной версии.

· Передача файлов по FTP: Используя эту опцию, можно загрузить файлы или папки на сервер FTP. После выбора надлежащего типа, файлы или папки должны быть определены и разделены точкой с запятой (;).

Для передачи файлов требуется ввести имя сервера FTP или IP адрес, имя пользователя и пароль, если требуется. Дополнительно порт передачи (значение по умолчанию 21, стандартный порт FTP), опцию пассивного режима и удалённой папки также можно определить. Кнопка Настроить открывает окно с большим количеством опций для управления передачей, включая поддерживаемые опцию архивирования, тайм-аута FTP и максимального количества повторений.

Примечание: Опция "сохранять последние XX архивов" может использоваться с передачей по FTP. Функция Продолжить (REST) не поддерживается.

Примечание: эта функция доступна только в зарегистрированной версии.

· Тест диска(ов): Можно изучать и тестировать жёсткие диски используя функцию тест аппаратными средствами (поддерживаемую IDE и S-ATA дисками). Диски, которые нужно тестировать, необходимо выбрать, иначе будут тестироваться все установленные жёсткие диски одновременно.

Если переместить мышь на жёсткий диск, предусмотренные тесты отобразятся в подсказке. Пожалуйста, выберите тип желаемого теста.

Можно отправить сообщение после завершения теста (всегда или если произошла ошибка). Сообщение содержит детали теста, включая любые новые найденные проблемы (например, сбойные сектора).

Примечание: эта функция доступна только в зарегистрированной версии.

Примечание: следующие версии программы могут иметь больше различных типов проектов.

Кнопка Запуск может использоваться для немедленного запуска проекта. Всегда используйте кнопку Сохранить, чтобы сохранять любые изменения в опциях проекта.

Используя кнопку [image] , Hard Disk Sentinel создаст ярлык на рабочем столе для текущего проекта. Ярлык можно использовать, чтобы запустить связанный с ним проект (даже когда Hard Disk Sentinel не активен).

Примечание: если проект содержит переменные, то они определяются во время создания ярлыка. Таким образом, не рекомендуется использовать переменные в проектах, которые запускаются вручную, или используйте только постоянные переменные (например, %COMPUTER %).

Примечание: эта функция доступна только в зарегистрированной версии.

Кнопка Сохранить должна использоваться для сохранения изменений в конфигурации. Это сохранит текущий список проектов, список запланированных операций и список определённых событий. Рекомендуется чаще использовать эту кнопку, потому что некоторые опции становятся доступны только при сохранении резервной конфигурации. При использовании кнопки Восстановить Проекты по Умолчанию, можно перезагрузить предварительно сохранённую резервную конфигурацию. Это может быть полезно при случайном удалении или изменении.

После того, как резервные проекты определены, они должны быть связаны с определённым временем и датой на вкладке планировка или с различными событиями. Таким событием может быть резервное копирование. Оно будет запущено в случае, если при проблеме, найденной на любом жёстком диске и началом резервного копирования, опция для этого разрешена на вкладке предупреждений.


Ïëàíèðîâêà

Конфигурация: Операции, Планировка

Эта функция доступна только в версии PROFESSIONAL.

На этой вкладке можно создать список проектов и назначить их запуск на любой день недели. В меню Запуск в пользователь может выбрать день недели, чтобы исследовать выбранные проекты и добавить/рассмотреть конфигурацию.

Используя опцию Приостановить на следующий день, можно отключить последующий запуск всех выбранных проектов. Например, если запуск проекта назначен на вторник и эта опция включена, то проекты, намеченные на вторник, в следующий вторник выполняться не будут. Таким образом, можно временно отключить запуск запланированных проектов. После того, как намеченный день пройдёт, приложение автоматически восстановится в нормальный режим и все проекты будут запускаться, как и прежде. Администратору не стоит волноваться о ручном отключении и последующем восстановлении проектов после того, как их работа завершится.

Красный значок X под надписью Удалить используется для удаления соответствующего проекта из списка. Конечно, сам проект не будет удалён и может быть выбран снова любое время. Затем (слева направо) показан номер проекта. Это важно, если пользователь хочет создать цепочку проектов (запускать проекты последовательно, один после одного).

Под надписью Проект отображено имя проекта. Пользователь может выбрать проект для выполнения из списка прежде созданных проектов.

В колонке Запуск можно установить время запуска проекта. Возможны следующие варианты:

· Время: проект будет запущен в то время, какое определено в колонке Время (час:минута). Если невозможно запустить его в заданное время (например, система не готова из-за проблем с питанием), проект можно запустить позднее в доступное время. Этим можно управлять, включив опцию Запуск позже. Рекомендуется для выполнения фиксированных, ранее намеченных проектов (например, полное резервное копирование ночью).

· После загрузки: запуск проекта после старта Hard Disk Sentinel и истечения выбранной задержки времени. Задержку можно настроить в колонке Время (час:минута). Проект будет выполняться после каждого перезапуска Hard Disk Sentinel. Если система должна регулярно перезагружаться, то этот проект будет также запускаться после каждой её перезагрузки. Рекомендуется для быстрого резервного копирования (например, сохранение новых или изменённых документов, изображений).

· После загрузки 1/день: запуск проекта после старта Hard Disk Sentinel и истечения выбранной задержки времени. Задержку можно настроить в колонке Время (час:минута). Проект будет выполняться всегда после первого запуска Hard Disk Sentinel, таким образом, это будет происходить максимум один раз в день. Рекомендуется для задач, выполняемых раз в день, например, обновление антивирусных баз.

· Повторить: повторить запуск проекта после заданного периода. Период можно задать в колонке Время (час:минута). Рекомендуется для сохранения часто изменяемых данных, файлов, изображений.

· После X: запуск проекта, когда завершится другой проект с номером X. Доступно, если проект с номером X сохранён в списке проектов.

Примечание: если какой-нибудь проект в цепочке отменён пользователем или пользователь отказался запустить проект в заданное время, то все дальнейшие проекты, которые зависят от отменённого, запущены не будут. Можно соединить несколько проектов с предварительно законченным проектом (если проекты имеют статус запуска "После X"). Таким образом, эти проекты будут запущенны одновременно, но только после того, как завершится проект с номером X. Рекомендуется для: сжатие заархивированных файлов, прожига файлов на оптический носитель.

Если выбрана опция Запрос запуска, то проект не будет выполняться автоматически. Вместо этого будет показано окно подтверждения с названием и комментариями проекта, и пользователь должен подтвердить запуск проекта. Таким образом, пользователь может задержать выполнение проекта (и всех последующих, зависящих от него) пока не нажмёт кнопку подтверждения. Если он отменит выполнение, то проект и все зависящие от него запущены не будут.

Примечание: эта опция может быть отключена только в зарегистрированной версии. В незарегистрированной версии всегда необходимо подтверждение выполнения.

С неактивной опцией Включено, проект окажется заблокирован и запущен не будет. Это означает, что проект может быть заблокирован длительное время, без удаления из списка проектов.

Примечание: если один или несколько проектов зависят от отключенного, то они также выполняться не будут. Hard Disk Sentinel отображает предупреждение об этой ситуации и пользователь сможет просмотреть настройки проектов.

Нажмите Добавить новый проект в список, чтобы добавить новый проект к ежедневному списку запланированных.


Ðåçåðâíàÿ êîïèÿ

Конфигурация: Операции, Резервная копия

Эта функция доступна только в версии PROFESSIONAL.

Можно подключить выполнение проекта к другим событиям, как на вкладке Планировка. Например, если значение здоровья одного из жёстких дисков слишком низкое или температура высокая, то проект может быть выполнен. Пользователь должен определить на вкладке Предупреждений различные типы проблем, когда проект должен быть запущен.

Также можно определить общий проектный список. Все проекты из этого списка будут выполняться, если у какого-нибудь жёсткого диска произойдёт проблема (и "резервное копирование" разрешено для соответствующей проблемы на вкладке Предупреждений). Кроме того, пользователь может создать разные проектные списки для каждого установленного жёсткого диска. Таким образом, можно назначить, чтобы происходила регулярная архивация важных данных на первом или втором жёстком диске, в случае, если у первого диска есть проблемы со здоровьем или если есть проблемы со вторым диском, а данные должны быть скопированы на внешний диск или удалённый сервер.

В ниспадающем меню рядом с пунктом Диск можно выбрать необходимый диск или общий проектный список (выбор опции "любой жёсткий диск").

Красный значок X под надписью Удалить используется для удаления соответствующего проекта из списка. Конечно, сам проект не будет удалён и может быть выбран снова любое время. Затем (слева направо) показан номер проекта. Это важно, если пользователь хочет создать цепочку проектов (запускать проекты последовательно, один после одного).

Под надписью Проект отображено имя проекта. Пользователь может выбрать проект для выполнения из списка прежде созданных проектов.

В колонне Запуск можно выбрать функцию запуска проекта. Возможны следующие варианты:

· Автоматически: немедленный запуск проекта в случае обнаружения проблемы..

· После X: запуск проекта, когда завершится другой проект с номером X. Доступно, если проект с номером X сохранён в списке проектов.

Примечание: если какой-нибудь проект в цепочке отменён пользователем или пользователь отказался запустить проект в заданное время, то все дальнейшие проекты, которые зависят от отменённого, запущены не будут. Можно соединить несколько проектов с предварительно законченным проектом (если проекты имеют статус запуска "После X"). Таким образом, эти проекты будут запущенны одновременно, но только после того, как завершится проект с номером X.

Если выбрана опция Запрос запуска, то проект не будет выполняться автоматически. Вместо этого будет показано окно подтверждения с названием и комментариями проекта и пользователь должен подтвердить запуск проекта. Таким образом, пользователь может задержать выполнение проекта (и всех последующих, зависящих от него) пока не нажмёт кнопку подтверждения. Если он отменит выполнение, то проект и все зависящие от него запущены не будут.

Примечание: эта опция может быть отключена только в зарегистрированной версии. В незарегистрированной версии всегда необходимо подтверждение выполнения.

С неактивной опцией Включено, проект окажется заблокирован и запущен не будет. Это означает, что проект может быть заблокирован длительное время, без удаления из списка проектов.

Примечание: если один или несколько проектов зависят от отключенного, то они также выполняться не будут. Hard Disk Sentinel отображает предупреждение об этой ситуации и пользователь сможет просмотреть настройки проектов.

Нажмите Добавить новый проект в список, чтобы добавить новый проект к ежедневному списку запланированных.


Ïåðåäà÷à ôàéëîâ

Конфигурация: Операции, Передача файлов

Зарегистрированная версия Hard Disk Sentinel PROFESSIONAL имеет внутренний модуль архиватора. Он содержит многочисленные настройки и при его использовании можно создать различные операции резервного копирования, подходящие для текущей ситуации. Настройки и функция описаны в следующих главах:

· Операции

· Настройки папки

· Общие настройки

· Опции проекта

· Передача файлов (обработка)


Íàñòðîéêè ïðîåêòà

Конфигурация: Операции, передача файлов, настройки проекта

Эта функция доступна только в зарегистрированной версии PROFESSIONAL.

Для того, чтобы настроить перемещение файлов и папок, необходимо определить исходную папку и папку назначения.

Нажатие кнопки Новый отобразит окно выбора папки, где они могут быть настроены. Кнопка Правка откроет это окно и, предварительно указанные значения, могут быть изменены (двойной щелчок на любом пункте этого списка также откроет это окно). При использовании кнопки Удалить, выбранный пункт будет удалён из списка

На вкладке Общие настройки можно настроить общие опции для всех проектов "передачи файлов и папок". На вкладке Опции проекта есть много опций для улучшения настроек выбранного проекта.


Íàñòðîéêè ïàïêè

Конфигурация: Операции, передача файлов, настройки папки

Эта функция доступна только в зарегистрированной версии PROFESSIONAL.

Для того, чтобы настроить перемещение файлов и папок, необходимо определить исходную папку и папку назначения.

Можно выбрать или ввести вручную путь к исходной папке и папке назначения. Допускается использование более одной папки (даже на разных дисках или разных компьютерах). Файлы из исходной папки будут скопированы во все такие папки назначения. Можно задать любую (одну или несколько) переменных при определении папки назначения. Например, можно создать различные папки на основе имени пользователя, имени компьютера или IP адреса. При необходимости, Hard Disk Sentinel автоматически создаст папку перед архивацией.

Переменная %LAST = папка% заменяется на имя недавно обновлённой подпапки из указанной "папки". Это полезно, если пользователь хочет сохранить больше различных резервных копий, но новые файлы нуждаются в дальнейшей обработке (например, прожиг последних файлов на оптический диск). Эта функция и её конфигурация будут описаны на вкладке опции проекта.

Можно использовать более короткую форму этой опции: указать только %LAST%. В этом случае, прежнюю папку %LAST% можно будет найти в самой последней архивной папке. Например, C:\BACKUP\%LAST=C:\BACKUP% и C:\BACKUP\%LAST%, т.е. результат будет тот же (последний архив C:\BACKUP). Если это требуется для записи CD/DVD и один из этих примеров приводится в качестве источника папки, то новая папка будет скопирована на оптический диск.

Примечание: %LAST=папка% и %LAST% могут быть использованы, только если включена опция Использовать текущую дату как имя папки и сохранять последние XX полных архива.

Примечание: имена папок можно указывать на локальных или удалённых (сетевых) дисках. Кроме того, можно указать UNC путь (например, \\server\share\folder). Пожалуйста, убедитесь, что соответствующие сетевые ресурсы доступны для приложения.


Îáùèå íàñòðîéêè

Конфигурация: Операции, передача файлов, общие настройки

Эта функция доступна только в зарегистрированной версии PROFESSIONAL.

Можно настроить, какие файлы (соответствующие указанным маскам файла) должны игнорироваться. Эти файлы не будут архивироваться.

Примечание: Настройки этой опции будет касаться всех проектов резервного копирования.


Îïöèè ïðîåêòà

Конфигурация: Операции, передача файлов, опции проекта

Эта функция доступна только в зарегистрированной версии PROFESSIONAL.

Используя эти опции, пользователь может настроить проекты резервного копирования.

Вычислить сумму данных, которые будут скопированы: перед началом процесса архивации Hard Disk Sentinel может подсчитать общее количество данных, которое необходимо заархивировать. В случае большого количества файлов и папок для резервного копирования этот процесс может занять много времени, и тогда эту функцию можно отключить. Если проект предназначен для "резервного копирования", то эта функция также должна быть отключена, чтобы начать архивирование как можно быстрее. Если эта опция включена, процесс и расчёт оставшегося времени отображается во время этой операции.

Не запускать, если данных меньше XX кбайт: архивация не будет запущена, если исходная папка не содержит указанного количества данных. С помощью этой опции можно сохранить существующие резервные копии и избежать копирования пустой папки или папки с неполным содержанием.

Оповестить, если недостаточно данных: будет создано предупреждение, если количество данных меньше указанного порога. Это может быть электронная почта, сетевое сообщение или предупреждающее окно на экране, в соответствии с настройками отчёта. Также можно настроить звуковое предупреждение (см. ниже).

Проверка скопированных данных: во время операции резервного копирования Hard Disk Sentinel автоматически создаёт контрольную сумму CRC для всех файлов и сохраняет эти значения вместе с файлами (с этой информацией модуль восстановления (будет доступно в будущем) сможет проверить целостность всех архивных файлов и автоматически их восстановить). Если эта опция включена, целостность архивных файлов будут проверена после архивации. Если количество архивных файлов слишком велико, то этот процесс может занять много времени (даже больше, чем сам процесс резервного копирования).

Копировать только новые и обновлённые файлы: архивируйте только новые или обновлённые файлы с момента последней операции резервного копирования.

Очистить архивный бит в скопированных файлах: Hard Disk Sentinel очищает архивный бит всех файлов после архивации. Это обеспечивает полную архивацию файлов. Рекомендуется использовать эту опцию с предыдущей.

Удалить исходные файлы после копирования: удалить все исходные файлы после завершения процесса архивации. Используйте эту функцию только в особых случаях (например, резервное копирование с устройства малой ёмкости и пустого устройства).

Примечание: папки (пустые) удалены не будут.

Сохранить подпапки: с этой опцией возможно заархивировать все файлы из всех подпапок исходных папок.

Сохранить исходное имя папки с её содержимым: Если эта опция включена, имя исходной папки (последний папки в исходном пути) будет также создано в папке назначения и все файлы и подпапки из исходной папки будут сохранены в этой папке. Если эта опция отключена, содержимое исходной папки будет сохранено непосредственно в папке назначения.

Не показывать окно сохранения: обычно окно процесса копирования отображается во время процесса архивации. Если эта опция отключена, оно не будет отображаться, только мигающая иконка в системном трее будет напоминать, что операция резервного копирования продолжается.

Использовать текущую дату как имя папки и сохранять последние XX полных архива: При включении этой опции содержимое исходных папок неоднократно сохраняется в папки назначения. Таким образом, можно иметь несколько различных полных резервных архивов. Например, если резервный проект настроен для ежедневного запуска и включена опция сохранения 7-ми архивов, то все файлы будут сохраняться в течение недели ретроактивным образом (т.е. все файлы будут сохранены 7 раз, одна резервная копия каждый день). Папка с текущей датой и временем будет создана автоматически в соответствии с папкой назначения, и исходные файлы будут сохраняться в неё. Если целевая папка уже будет содержать назначенное количество полных архивов, то самый старый архив будет автоматически удалён. Используя эту функцию, можно восстановить данные из стабильного архива за любой предыдущий день в случае возникновения проблем. Но здесь есть недостаток: требуется гораздо больше места, чем при простом резервном копировании.

Можно создать отчёт после выполнения резервного проекта. Он может быть создан во всех случаях (после отказа/проблемы или когда проект завершён без ошибок), или только тогда, когда появилась проблема. Кроме того, можно полностью отключить функцию создания отчётов по данному проекту. Отчёт может быть отправлен по электронной почте, передан, как сетевое сообщение или отображён на экране в окне предупреждений, в зависимости от настроек отчёта. При необходимости, в случае возникновения проблемы может быть включена звуковая сигнализация.

Включив опцию звукового оповещения о проблеме, звуковой сигнал будет сгенерирован в соответствии с настройками на вкладке Предупреждения.

Можно настроить приоритет операции. Устанавливая максимальный приоритет, проект будет выполнен в кратчайшие сроки. Это может снизить производительность других приложений, но таким образом файлы будут заархивированы быстрее. Рекомендуется использовать максимальный приоритет для срочных операций резервного копирования, а низкий или нормальный для других проектов.


Àðõèâèðîâàíèå ôàéëîâ

Передача файлов, архивирование файлов

Если проект настроен на "передачу файлов и папок" в окне конфигурации проекта, то внутренний модуль архиватора будет использоваться для архивирования. В ходе этого отобразится окно процесса с текущим действием (например, передача файлов, проверка архива и т.д.). Текущее состояние и оставшееся время будет отображено, если включена опция Вычислить сумму данных, которые будут скопированы.

Выполнение может быть отменено кнопкой Отмена. В этом случае, Hard Disk Sentinel создаст отчёт (если была включена опция создание отчётов) о том, что пользователь отменил в текущий момент выполнение проекта. Все другие проекты, которые зависят от отменённого, запущены не будут.

Примечание: в некоторых случаях процесс может выполняться ещё несколько секунд перед остановкой.

Можно использовать кнопку X (закрыть), чтобы закрыть (скрыть) окно процесса. Это не остановит операцию выполнения, а появившаяся иконка диска в системном трее укажет, что операция продолжается:

Hard Disk Sentinel отобразит текущую операцию и следующее действие, если навести указатель мыши на иконку в системном трее. Полное окно процесса может быть отображено щелчком левой кнопкой мыши (и таким же образом скроет иконку в трее).

Примечание: после завершения выполнения проекта, данные о состоянии или проблемах сохраняются в файле project_log.txt в папке Hard Disk Sentinel. Рекомендуется изучить этот файл в случае возникновения проблем.


Èíòåãðàöèÿ

Конфигурация: Интеграция

На этой странице можно настроить интеграцию приложения в систему. Данные опции и характеристики рекомендуется использовать только опытным пользователям.

Защита

Программа может быть защищена паролем. Не зная этот пароль, пользователь не сможет изучить и изменить текущие настройки. Так же можно защитить и главное окно информации, так что оно будет недоступно для просмотра, подобно жёсткому диску, без пароля.

Если включена защита, администратор может получить доступ к соответствующему окну после ввода правильного пароля. Программа запоминает пароли после закрытия информационного окна или в окне конфигурации и пользователю не нужно будет вводить его снова, за исключением, когда опция автоматического выхода из системы разрешена. В этом случае после истечения определённого времени, Hard Disk Sentinel потребует ввести пароль снова.

Системный администратор может использовать кнопку Выход из системы и выйти в любое время после проверки и изменения параметров. Это снова защитит пользовательский интерфейс паролем.

Примечание: Эта функция доступна только в зарегистрированной версии.

Служба

Hard Disk Sentinel может работать в двух различных режимах. Он может быть запущен как Приложение или как Служба. По умолчанию, установлен режим приложения: программа запускается после того, как пользователь (с соответствующими правами администратора) входит в систему. До версии 2.02 это был единственный режим.

При запуске Hard Disk Sentinel в качестве Службы NT, программа стартует вместе с операционной системой и работает, даже если пользователь не вошёл в систему или имеет ограниченные права. Таким образом, Hard Disk Sentinel работает независимо от текущего пользователя: программа может контролировать и проверять состояние жёсткого диска, запускать операции резервного копирования точно так же, как и в другом режиме.

Только системный администратор может управлять, устанавливать и удалять службы. Таким образом, администратор должен настроить приложение (например, установить пороговые значения, опции предупреждений), а затем перейти в режим Службы. Рекомендуется использовать предыдущую функцию (Защита) также для предотвращения несанкционированных изменений в конфигурации.

Примечания о режиме служба:

· Эта функция доступна только на NT операционных системах (Windows 2000, XP, 2003, Vista).

· Программа выполняет одни и те же функции в режиме службы и режиме приложения.

· Имя службы: HardDiskSentinelService и выполняется она в контексте безопасности "Локальная система". Администратор, при необходимости, может изменить это с помощью Панели Управления, Инструментов Администрирования и окна Служб (например, разрешить доступ для удалённых дисков и ресурсов). Настроенные проекты резервного копирования и внешние приложения наследуют назначенные права.

· Служба может быть запущена и остановлена из программной группы Hard Disk Sentinel с помощью надлежащего ярлыка. После остановки службы, можно полностью отключить её и вернуться обратно в режиме приложения. Для этого пользователь должен иметь права администратора и ввести правильный пароль (если была включена функция Защиты).

· Можно использовать программу в "скрытом" режиме (без отображения окна, иконки в трее, сообщений), если отключить опцию "Разрешить взаимодействие с рабочим столом" (в окне "Свойства Служб" операционной системы). В этом случае пользователь не сможет получить доступ к основной информации и конфигурации Windows - если он останавливает службу с помощью ярлыка "Стоп служба". Windows Vista не отображает пользовательского интерфейса для интерактивных служб, таким образом служба Hard Disk Sentinel работает в "скрытом" режиме под Vista.

· Используя программу в режиме службы, функция "обновление" становится недоступной и программа не может быть закрыта. Это можно сделать посредством ярлыка из группы Hard Disk Sentinel.

· Служба останавливается и запускается автоматически вместе с системой и пользователю не нужно останавливать её вручную перед выключением компьютера.

· Администратор должен отключить доступ к папке Hard Disk Sentinel для пользователей с ограниченными правами. Таким образом, пользователи не смогут изучить информацию и изменить настройки вне приложения.

· Некоторые системы, приложения или темы для рабочего стола могут сделать так, что некоторые части пользовательского интерфейса (окно состояния, информация на рабочем столе) не будут отображаться совсем или только частично.

· Когда автоматическое обновление используется для обновления с версии 2.00 или ниже, ярлыки "Запуск службы" и "Стоп служба" будут не доступны в программной группе Hard Disk Sentinel. Рекомендуется установить версию 2.05 (или выше) вручную, чтобы создать эти ярлыки.

· Можно запускать и останавливать службу с помощью Панели Управления, Инструментов Администрирования и окна Служб. Щелкните правой кнопкой мыши на HardDiskSentinelService и во всплывающем меню будут отображены команды запуска и остановки. Также это возможно с удалённого компьютера, если пользователь имеет соответствующие права.

· Если служба остановлена, то можно установить или удалить её с помощью команд удаления HDSentinel.exe /INSTALL или HDSentinel.exe /UNINSTALL в установочной папке Hard Disk Sentinel.

Удалённое Управление

Включить Веб-Статус: если он включён, то можно рассмотреть состояние жёсткого диска с локального или удалённого компьютера/мобильного телефона/КПК, используя веб-браузер. Дополнительно можно использовать пароль для предотвращения несанкционированного доступа. Таким образом, для подключения можно ввести любое имя пользователя и пароль на вкладке Защита.

Можно определить любой HTTP порт, согласно текущей конфигурации сети.

Примечание: Эта функция доступна только в зарегистрированной версии.

Когда эта опция включена, то в веб-браузере могут быть использованы следующие запросы:

· http://server:port/status : целое окно состояния со всем содержимым (согласно настройкам) с постоянным обновлением после указанного периода времени. Окно не имеет границ и краёв и может быть вставлено в IFRAME.

· http://server:port/statuswin.bmp : окно состояния (только изображение)

· http://server:port/report : детальный отчёт HTML, который содержит настроенные разделы отчёта

· http://server:port/xml : полный отчёт XML

Примечание: чтобы использовать эту функцию, окно состояния не должно отображаться на компьютере (сервере).

Например: если включена опция на локальном компьютере и используются настройки по умолчанию, введите http://localhost:61220/status в браузер и изучите информацию о жёстком диске.

Примечание: Все запросы регистрируются с IP и датой в файле "NetLog.txt". Запросы, кроме перечисленных выше, возвращают ошибку Запрета 403 в браузер. С этой функцией невозможно получить доступ к файловой системе или любой другой информации.

Примечание: если компьютер (сервер) имеет динамический IP адрес, то обязательно использовать службу dynamic DNS provider (перевод динамического IP адреса в фиксированное имя хоста), чтобы можно было удалённо обратиться к компьютеру. Эта служба находится в свободном доступе на (например) http://www.no-ip.com и http://www.dyndns.com .

Окна состояния Hard Disk Sentinel с двух или более компьютеров могут быть легко объединены на одной веб-странице (с автоматическим обновлением для отражения текущего состояния). Таким образом, можно исследовать состояние различных конфигураций удалённо, открыв эту страницу (файл HTML, который может быть на сетевом файловом сервере или непосредственно на ПК/Телефоне/КПК) в браузере. Например:

<html>

<head>

<title>Hard Disk Sentinel Status</title>

</head>

<body>

<center>

<iframe src="http://192.168.2.101:61220/status" width=220

height=61 frameborder=0></iframe><br>PC #1<br><br>

<iframe src="http://192.168.2.102:61220/status" width=220

height=61 frameborder=0></iframe><br>PC #2<br><br>

<iframe src="http://192.168.2.103:61220/status" width=220

height=61 frameborder=0></iframe><br>PC #3<br><br>

</body>

</html>

Отображает 3 окна состояния в IFRAMEs (обновляются автоматически, но раздельно).

<html>

<head>

<title>Hard Disk Sentinel Status</title>

<META HTTP-EQUIV="Refresh" CONTENT="300">

<META HTTP-EQUIV="Pragma" CONTENT="no-cache">

<META HTTP-EQUIV="Expires" CONTENT="-1">

<META HTTP-EQUIV="CACHE-CONTROL" CONTENT="NO-CACHE">

</head>

<body>

<center>

<a href="http://192.168.2.101:61220/report"><img

src="http://192.168.2.101:61220/statuswin.bmp" border=0></a><br>PC #1<br><br>

<img src="http://192.168.2.102:61220/statuswin.bmp"><br>PC #2<br><br>

<img src="http://192.168.2.103:61220/statuswin.bmp"><br>PC #3<br><br>

</body>

</html>

Отображает 3 окна состояния и обновляет их каждые 300 секунд. После нажатия мышкой на первом окне, отобразится полный отчёт о компьютере.

Сохранённый файл HTML, открытый в браузере КПК.

Принять удалённое подключение от сервера: Hard Disk Sentinel Enterprise можно использовать для удалённого анализа проблем с жёстким диском, проверки состояния и тестирования жёстких дисков на компьютерах с запущенным клиентом Hard Disk Sentinel. Если эта опция разрешена, сервер может посылать команды и получать информацию об этом компьютере.

Включить службы DynDNS, No-IP и Dynamic DNS: С помощью этих служб можно установить имя хоста для компьютеров с изменяющимся (динамическим) IP адресом. С таким постоянным именем хоста можно получить удалённый доступ к компьютеру, таким образом удалённое управление (веб-статус, удалённые соединения) станет возможным.

Требуется настроить и зарегистрировать одну из перечисленных служб. Тогда имя пользователя, пароль и зарегистрированное имя хоста должны быть также настроены и в Hard Disk Sentinel. Позже, когда приложение обнаружит, что IP адрес компьютера изменился, оно автоматически обновит это для соответствующего хоста в течение 1 минуты. Таким образом, удалённый доступ станет возможен после повторного подключения к сети.

Кнопка "Настроить" используется для указания имени пользователя, пароля и имени хоста для определённого провайдера Dynamic DNS. После обновления IP, последний ответ сервера может быть проверен перемещением курсора мыши на соответствующую опцию Dynamic DNS. Этот ответ полезен для диагностики любой проблемы (например, неправильное имя пользователя).


Îòïðàâêà Îò÷¸òà

Конфигурация: Отправка тестового отчёта

На этой странице можно создать тестовый отчёт с подробной информацией проверки и отправить его разработчику. У такого отчёта может быть более подробная информация (по сравнению с полным, но отформатированным HTML или текстовым) об обнаруженных жёстких дисках, их типе и деталях. Эти данные помогут изучить возможные проблемы и улучшить приложение, поэтому, пожалуйста, отправляйте такие отчёты по адресу: reports@hdsentinel.hu

Отчёт может быть отправлен сразу же после его создания. Hard Disk Sentinel автоматически загрузит его на www.hdsentinel.com. Если не будет активного подключения к Интернету, отчёт может быть сохранён в файл нажатием кнопки Сохранить и пользователь сможет отправить его позже (или с другого компьютера).


Òåñòû æ¸ñòêîãî äèñêà

Тесты жёсткого диска

В данном разделе описаны различные тесты жёсткого диска, доступные в Hard Disk Sentinel. Рекомендуется внимательно прочитать эти страницы (особенно общую информацию), прежде чем использовать любой из этих тестов.

· Общая информация, ответы о тестах диска

· Тест аппаратными средствами: короткий, расширенный и тест передачи

· Тест подвода головки

· Тест поверхности


Îáùàÿ èíôîðìàöèÿ

Тесты - Общая информация

Как такое возможно, что состояние здоровья жёсткого диска является низким, текстовое описание показывает сбойные сектора, а тесты не показывают каких-либо проблем?

Когда жёсткий диск находит сбойные сектора, он пытается сохранить (перераспределить) содержимое из этих секторов в резервные области. После завершения этой операции, делается отметка расположения этих секторов и диск их больше не использует: все дальнейшие операции чтения и записи будут перенаправлены к резервным секторам. Таким образом, тесты (которые проводят тестирование не только программным обеспечением) могут получить доступ только к этой изменённой поверхности. В оптимальном варианте поверхность диска действительно становится совершенна - проблемы устранены, плохие области больше не используется. Проблема может возникнуть только тогда, когда плохая область является относительно большой (здоровье становится низким) и образуется всё больше и больше проблем (например, слабых и сбойных секторов). Чтобы решить эти вопросы, рекомендуется использовать тесты, встроенные в Hard Disk Sentinel, поскольку они могут проверить и исправить проблемы в управляемой среде. Для получения дополнительной информации о проблемах, смотрите раздел текстовое описание.

Все тесты предназначены для выявления неполадок жёсткого диска. Здоровье рассчитывается исходя из проблем, обнаруженных на жёстком диске, но тест может привести к снижению здоровья. Здоровье может увеличиться, только если проблемы будут "скрытыми" (а не установленными!). Но это невозможно - за исключением, если у диска были слабые сектора перед тестом и их количество может уменьшиться (приблизиться даже к нулю). Количество других обнаруженных и установленных проблем на жёстком диске не может быть уменьшено, а состояние стать удовлетворительным. Однако, используя колонку "смещение" на странице S.M.A.R.T., эти проблемы могут быть проигнорированы, если состояние диска стабильное. Для получения дополнительной информации, пожалуйста, посмотрите разделы текстовое описание и калибровка температуры.

Почему тест находит больше или меньше сбойных секторов, чем отображено в текстовом описании?

Сбойные сектора, которые появляются в текстовом описании, уже перераспределены жёстким диском и больше не используются. Сбойные сектора, показанные тестом всё ещё находятся на активной поверхности и, таким образом, могут вызвать потерю данных. Нашей целью является принуждение жёсткого диска к перераспределению этих секторов, чтобы в дальнейшем их больше не использовать. После такой операции диск работает лучше (хотя значение здоровья может снизиться).

Можно ли улучшить здоровье? Может ли оно быть восстановлено до 100%?

Если на жёстком диске есть слабые сектора, то их состояние может быть улучшено во время тестов. Это может привести к росту значения здоровья, даже до 100%, если нет других проблем, обнаруженных на диске. В любом случае, здоровье может уменьшиться, если состояние диска нестабильно и выявлены новые проблемы.

Если диск является стабильным: здоровье не меняется даже после многих проходов теста записи, предыдущие проблемы могут быть очищены на странице S.M.A.R.T. с помощью колонки Смещение. Таким образом, можно восстановить здоровье до 100%.

Гарантийная замена возможна только при значении здоровья равным 0 %. Если здоровье выше (но низкое), рекомендуется запустить тесты (даже несколько раз), чтобы выявить пока ещё не обнаруженные проблемы.

Почему хорошо использовать тесты дисков Hard Disk Sentinel? Почему не достаточно просто скопировать файлы (вынужденное перераспределение)?

В ходе тестов программным обеспечением жёсткие диски находятся под лучшим контролем и мониторингом, чем простые операции с файлами. Файловая система размонтируется для предупреждения доступа операционной системы и другого программного обеспечения к диску, чтобы её состояние (например, фрагментация) не повлияло на тесты. Производительность блоков, счётчик повторов, здоровье и температура диска - все эти факторы постоянно контролируются в ходе теста. Можно даже проверить содержимое сектора в любое время. Как хирургия возможна только в больнице, так тестирование и ремонт жёсткого диска имеют свою собственную управляемую среду.

Типы Тестов

Вообще, доступны два различных теста: тест аппаратными средствами и тест программным обеспечением (оба доступны в Hard Disk Sentinel). Более поздний раздел содержит тест подвода головки, который является специальным тестом, поскольку не делает проверку поверхности, а только ищет функциональные возможности диска.

Тесты аппаратными средствами являются более эффективным, чем тесты программным обеспечением, поскольку они исследуют компоненты дисковой системы (например, головку, сервомотор, электрические компоненты и т.д.) специальным методом, который невозможен с использованием программ такого рода. Тесты не затрагивают сохранённую информацию, так что они могут использоваться в любое время (на IDE и S-ATA дисках, которые их поддерживают) без какой либо специальной подготовки или резервного копирования. Рекомендуется периодически использовать тесты аппаратными средствами, особенно на безупречных дисках, чтобы выявить любые скрытые проблемы.

В некоторых случаях, тесты аппаратными средствами не доступны, не поддерживаются или быстро заканчиваются с ошибками даже при относительно низком количестве проблем. Никакая дальнейшая информация о результатах не возвращается (например, невозможность внесения в список повреждённых секторов). В этом случае для их тестирования требуется соответствующее программное обеспечение.

Когда мы говорим о тестировании программным обеспечением важно знать, что операция ЗАПИСИ, затрагивающая дисковую поверхность, является самой важной: она вынуждает жёсткий диск проверять целостность секторов, перераспределять их (если это требуется) и восстанавливать слабые сектора. Из-за этого все тесты типа ЧТЕНИЯ (например, scandisk) не могут использоваться для восстановления дисковых проблем (и во многих случаях они даже не могут обнаружить такие проблемы). Scandisk проверяет и устанавливает только логические ошибки (связанные с файловой системой), которые не касаются физического состояния диска. Это одна из причин, почему они обычно исчезают после полного перераспределения и форматирования диска.

Тесты ЗАПИСИ обычно являются разрушительными, поскольку они должны перезаписать находящиеся данные. В любом случае будьте очень осторожны перед запуском этих тестов и обязательно сделайте резервную копию всех данных!

Тесты программным обеспечением рекомендуется использовать менее часто по сравнению с тестами аппаратными средствами. Они полезны когда:

· в системе установлен новый жёсткий диск

· самодиагностика аппаратными средствами завершается с ошибкой

· жёсткий диск подозрительно себя ведёт (например, издаёт странные шумы) и/или изменяется значение его здоровья

· обязательно требуется обновить сохранённые данные на жёстком диске или устройстве SSD/флэш (без их стирания). Это рекомендуется использовать периодически для предотвращения эффекта "забывания" ячейкой сохранённой информации. Частота обновления основывается на фактическом использовании устройства.

В таких случаях сначала рекомендуется использовать тест чтения, который не влияет на сохранённые данные. Тест чтения не может исправить ошибки, но может показать, какие области диска не совершенны, повреждены или слабо доступны, а также отобразить температуру и характеристики производительности диска. Реально проверить и исправить ошибки может последующий тест записи. В случае большого количества проблем рекомендуется сделать резервную копию данных и повторить тест поверхности диска (даже с уровнем 3 или выше). Другое программное обеспечение может (неверно) назвать более простую версию этого теста как форматирование на нижнем уровне.

ВАЖНО: Разработчик не даёт никаких гарантий за сохранение данных на любых дисках! В любом случае рекомендуется сделать копию ВСЕХ ДАННЫХ и тщательно прочитать описание тестов перед их запуском.


Òåñò àïïàðàòíûìè ñðåäñòâàìè

Тест аппаратными средствами

Самодиагностика аппаратными средствами для IDE и Serial ATA жёстких дисков являются идеальным решением для быстрой проверки их состояния с очень высокой детализацией. Обычно короткая и расширенная самодиагностики поддерживаются жёсткими дисками, но некоторые модели поддерживают и другие тесты, например тест передачи. Список всех поддерживаемых тестов и предполагаемое время их исполнения отображён на странице Информации жёсткого диска.

Самотестирование не является разрушительными, оно не затрагивает данные, сохранённые на жёстком диске. Во время теста жёсткий диск можно использовать, но работа его будет замедленной. И наоборот, использование жёсткого диска во время теста может сделать сам тест очень продолжительным. Это важно для системного жёсткого диска, где операционная система или другое программное обеспечение может вызвать трудоёмкие операции чтения/записи.

Короткая самодиагностика проверяет главные компоненты жёсткого диска (головки чтения/записи, сервомотор, электроника, внутренняя память и т.д.). Этот тест занимает всего несколько минут.

Расширенная самодиагностика выполняет вышеупомянутые действия и производит полное сканирование поверхности диска, чтобы выявить проблематичные области и сделать перераспределение сбойных секторов. Рекомендуется периодически использовать этот тест для проверки здоровья диска, особенно если его значение меньше 100%.

Самодиагностика Передачи (если поддерживается) выполняет определённые производителем тестовые шаги. Обычно проверяются механические части жёсткого диска для гарантии, что никаких повреждений при работе не произошло.

Дата и результаты (успешно или с ошибкой) последнего самотестирования показаны на странице Информации. На ней все поддерживаемые тесты жёсткого диска могут быть запущены вручную, или можно настроить автоматические (запланированные) тесты на странице Операции (только в версии Professional).


Òåñò ïîäâîäà ãîëîâêè

Тест подвода головки

Этим тестом можно проверить уровень шума, время перехода с дорожки на дорожку и температурные уровни жёсткого диска, особенно при интенсивном его использовании.

Тест очень полезен после изменения акустического уровня, чтобы проверить, как эти новые настройки влияют на шум и время подвода головки. Эта проверка может быть сделана коротким (быстрым) тестом.

Тест может быть использован для проверки стабильности и увеличения температуры диска за длительный период времени интенсивного использования. Вполне возможно, что в ходе тестирования температура может повыситься на 10-15 градусов по Цельсию (в сравнении с периодом простоя). Поэтому, если жёсткий диск был слишком горячим перед началом теста, рекомендуется контролировать процесс тестирования и отменить его при достижении критического уровня температуры.

Рекомендуется также использовать этот тест после установки нового жёсткого диска. Более длительное тестирование (от 8 часов или выше) можно использовать как стресс-тест (тест под нагрузкой) для проверки стабильности диска.

Тест можно запускать, даже если самодиагностика аппаратными средствами завершается с ошибкой или не поддерживается жёстким диском. Тест безопасен, не затрагивает сохранённые данные, а только позиционирует головки чтения/записи диска.

Примечание: в незарегистрированной версии допускается только короткий тест (2 минуты) и лишь для одного диска.


Òåñò ïîâåðõíîñòè

Тест поверхности

При использовании этого теста можно исследовать поверхность жёсткого диска другими методами. Некоторые из них безопасны для сохранённых данных, но другие являются разрушительными: сохранённая информация будет постоянно стираться во время процесса тестирования.

Сначала необходимо выбрать жёсткий диск и тип теста, который будет запущен. Подробное описание теста отображается после его выбора, где рассказывается о его воздействии на сохранённые данные. Настоятельно рекомендуется тщательно прочитать эту информацию перед началом тестирования.

Доступны следующие тесты:

Тест ЧТЕНИЯ - Чтение поверхности диска для проверки доступности и корректности всех секторов. Тест является безопасным, он не влияет сохранённые данные.

Дисковые проблемы могут остаться скрытыми и показать, что они НЕ установлены (как со ScanDisk).

Тест ЗАПИСЬ - Записывает данные на поверхность диска согласно настроенному шаблону. Принудительно анализирует любые слабые сектора, проверяет скрытые проблемы и устраняет их путём перераспределения сбойных секторов (регенерация диска).

Позволяет более эффективно использовать диск, так как после теста свободная область будет использоваться вместо любых проблематичных секторов.

Тест ЗАПИСЬ + чтение - Записывает данные на поверхность диска согласно настроенному шаблону, а затем обратно считывает содержимое сектора, чтобы проверить их доступность и согласованность. Принудительно анализирует любые слабые сектора, проверяет скрытые проблемы и устраняет их путём перераспределения сбойных секторов (регенерация диска).

Позволяет более эффективно использовать диск, так как после теста свободная область будет использоваться вместо любых проблематичных секторов.

Тест чтение + ЗАПИСЬ + чтение (обновление области данных) - Считывает сохранённую информацию из каждого блока, записывает обратно данные и, наконец, считывает их, сравнивая с оригинальным содержанием. В расширенном тесте, для повышения эффективности исправления ошибок, используется дополнительный цикл записи перед обратной записью содержания (регенерация диска).

Операция обычно безопасна для сохранённой информации, но данные можно потерять, если система нестабильна, при сбое питания, разгоне, проблем с памятью/блоком питания/кабелем или других факторов.

Тест может быть использован для обновления области данных накопителя без необходимости их полного удаления, но по-прежнему рекомендуется сделать резервную копию важных данных перед началом этого теста.

Повторная инициализация диска - Записывает данные на поверхность диска согласно настроенному шаблону инициализации для восстановления состояния секторов, по умолчанию (пустого), и считывает обратно содержимое сектора для проверки доступности и согласованности. Принудительно анализирует любые слабые сектора, проверяет скрытые проблемы и устраняет их путём перераспределения сбойных секторов (регенерация диска).

Позволяет более эффективно использовать диск, так как после теста свободная область будет использоваться вместо любых проблематичных секторов.

Очень интенсивный и отнимающий много времени тест, особенно если количество циклов перезаписи установлено на высокое значение.

В других приложениях простую версию этого теста обычно (ошибочно) называют форматированием нижнего уровня. Это можно эффективно использовать для надёжного удаления информации по стандарту NAVSO P-5239-26.

Каждый тест имеет различные варианты конфигурации:

В общем, можно настроить порядок прохода блоков в тесте и указать произвольное число повторений (программа будет повторно выполнять тест указанное количество раз), и можно размонтировать все логические тома (разделы) в ходе тестирования. При этом настоятельно рекомендуется запретить другим программам и операционной системе обращаться к диску во время его выполнения. Системный диск (содержащий операционную систему в корневой папке пользователя или файл подкачки в Windows) не могут быть заблокированы таким образом. Фактически из-за работающей системы на системном диске можно использовать только тест чтения (который не влияет на сохранённые данные).

Примечание: некоторые тесты и их настройки доступны только в версии Professional.

Примечание: Для предотвращения несанкционированного использования тестов (особенно тестов записи) программа запрашивает установленный пароль перед открытием окна тестирования.

Детали Теста

Программа делит область данных на 10000 блоков, определяя карту поверхности диска. Если щёлкнуть мышкой на каком-нибудь блоке, отобразится содержимое сектора в рамках выбранного блока. Таким образом можно проверить имеющиеся данные и/или записанные после проведения теста записи. Можно изучить содержимое сектора (и загрузить обратно результаты ранее сохраненного теста) без запуска теста, нажав кнопку Вид. Это безопасно для сохранённых данных на диске.

Во время тестов Hard Disk Sentinel проверяет целостность каждого сектора в рамках отображаемых блоков. Если блок доступен и может быть обработан без ошибок, то он показан зелёным цветом. Тёмно-зеленый цвет означает, что сектора медленные и их труднее обрабатывать. Программа отфильтровывает эффект замедления времени передачи в конце диска. Если к секторам трудно получить доступ и они могут быть обработаны только после нескольких попыток, то блоки повреждены, но исправлены и программа выделяет их жёлтым цветом. Красный цвет означает, что сектора в блоке не могут быть обработаны (чтение или запись - согласно выбранного теста). Дальнейший тест ЗАПИСИ может быть необходим для принуждения диска к перераспределению проблематичных секторов в блоке.

В случае обнаружения повреждённых или плохих блоков рекомендуется проверить всю поверхность с данными одним или несколькими тестами ЗАПИСИ. Во время тестов записи программа вынуждает жёсткий диск проверить состояние секторов на поверхности и перераспределить их в резервную область. Таким образом, изначально плохой сектор не будет использоваться и все дальнейшие операции чтения /записи будут перенаправлены в резервные области. Это называется регенерацией. В результате жёсткий диск функционирует лучше и, возможно, что в следующих тестах он покажет только хорошие (зелёные) блоки, так как плохие сектора больше не используются. Побочным эффектом является то, что регенерация диска может уменьшить его здоровье, поскольку выявляется все больше и больше проблем. Такое восстановление обычно не улучшает здоровье (за исключением случаев стабилизации состояния найденных слабых секторов).

Во время тестов, если найден поврежденный блок, вполне возможно, что программа и/или операционная система перестанут отвечать в ходе перераспределения. Это может занять несколько минут или даже часов - в зависимости от размера поражённого участка поверхности диска. Не рекомендуется отменять операцию, перезагружать или выключать питание компьютера. Вполне возможно, что контроллер диска или его драйвер могут отключиться и не реагировать на диск, так что он исчезнет из системы. Наиболее вероятно это может произойти с дисками, подключенными через разъём USB. Если это случится, то рекомендуется подключить жёсткий диск непосредственно к материнской плате или через другой контроллер и запустить тест снова.

Рекомендации к использованию тестов: запустите расширенный тест записи (например, "Повторная инициализация диска") для проверки поверхности диска, который очень удобен для проверки и перераспределения секторов. Подобно тесту подвода головки, программа измеряет температуру во время этих тестов, так что максимально возможная температура может быть измерена при критической нагрузке. Тесты могут быть запущены и для других типов запоминающих устройств (не только для жёстких дисков), например, для устройств SSD, карт-памяти, флэш-накопителей,. Они могут быть проверены тестом "чтение - запись - чтение", который эффективно используется для предотвращения потери данных, вызываемых эффектом "забывания" ячейками памяти.

Тесты могут быть полезными, даже если тест аппаратными средствами завершается с ошибкой, не поддерживается или не доступен.

Примечание: Незарегистрированная версия не позволяет запуск любого из тестов. В незарегистрированной версии возможен только просмотр содержимого секторов.

Примечание: во время тестов программы и операционная система, работающие в фоновом режиме, могут повлиять на производительность (и на результирующий цвет) каждого из блоков. Для минимизации этого эффекта, программное обеспечение препятствует запуску скринсейвера, предотвращает вход любого компьютера в режим ожидания или режим управления пониженным питанием, используя более высокий приоритет. В любом случае, на время теста рекомендуется закрыть все другие приложения, работающие в фоновом режиме и повторить тестирование, если происходит уменьшение производительности на большей площади (а не только блоков 1-1). Программа может повторить тест, чтобы минимизировать это мгновенное уменьшение производительности.

Примеры

В конце карты ясно видно, что область данных плохая. Испорченные блоки формируют непрерывные области, создавая серьезную проблему поверхности диска. Обратите внимание на жёлтый повреждённый блок в нижнем левом углу: соседствуя с плохим блоком он, вероятно, скоро станет непригоден для дальнейшего использования. Даже не повреждённые блоки являются очень трудно доступными. Рекомендуется проверить курсором мыши расположение первого проблематичного блока и создать раздел, который не будет использовать данные области.

Жёсткий диск показал много проблем. Он остановился во время операции чтения/записи, а состояние его здоровья является относительно низким (30%). Были обнаружены различные сбойные, повреждённые и трудно доступные блоки.

Тот же диск после многократно проведённого теста "Повторная инициализация диска". Слабые сектора установлены, сбойные - перераспределены (здоровье сократилось до 20%), но общая поверхность улучшилась, и диск можно использовать в течение некоторого времени (но из-за проблем не рекомендуется для хранения важных данных).

Типично низкий уровень здоровья жёсткого диска (22%). Многократные тесты записи (особенно повторной инициализации диска) могут улучшить его состояние, но не рекомендуется использовать первую половину данного диска (создавать раздел(ы) только на второй половине).


Ïðèëîæåíèå

Приложение

Общая информация о технологии S.M.A.R.T. и функциях Hard Disk Sentinel описана в следующих главах:

· Значения производителя и исходные значения

· Расчёт здоровья

· Расчёт производительности

· Время работы

· Калибровка температуры

· Известные атрибуты S.M.A.R.T.

· Текстовое описание


Çíà÷åíèÿ ïðîèçâîäèòåëÿ è èñõîäíûå çíà÷åíèÿ

Значения производителя и исходные значения

Как описано на странице S.M.A.R.T. жёстких дисков, Вы можете увидеть, что оценка атрибутов возможна при использовании метода, определённого производителем (проверка значений и наихудших областей) или при использовании различных методов, которые не зависят от производителя (проверка области данных). Как эти два метода работают и каково их различие?

Значения, определённые производителем

Текущее состояние жёстких дисков постоянно исследуется многими датчиками. Исходные измеренные значения сохранены в поле "Данные" соответствующего атрибуты S.M.A.R.T. и оцениваются алгоритмом, закодированным непосредственно в прошивке жёсткого диска.

После оценки производителем, конкретный результат для атрибута хранится в поле Значение. Он указывает, насколько "хорош" атрибут по сравнению с пороговым значением. Если жёсткий диск новый (никогда не использовался раньше), то это значение имеет теоретически максимальное значение, а затем уменьшается, пока не достигнет порогового уровня.

Таким образом, атрибут будет отличным, если следующее неравенство ИСТИННО:

A - f(r) ≥ C

Где:

· A - теоретически максимальное значение, наилучшее из возможных значений для данного атрибута.

· f - Функция для вычисления декремента на основе исходных (r) значений. Обычно это линейная функция, поэтому r умножается на константу B.

· C - пороговый уровень, определённый изготовителем. Если значение ниже, то атрибут считают проблематичным.

Используемый метод имеет некоторые недостатки. Значения A, B, C (или функции f) определены не точно (они могут варьироваться от модели к модели даже на двух жёстких дисках одного производителя). Другой недостаток заключается в том, что атрибуты оцениваются независимо, взаимосвязь между ними игнорируется.

В реальной жизни можно встретиться с неверными значениями, которые указывают неправильное состояние жёстких дисков. Некоторые производители могут определить 60-70 лет общей работоспособности жёстких дисков, что обнаруживается после изучения соответствующего атрибута. Кроме того, пользуясь этим методом, придётся выявить несколько тысяч сбойных секторов, пока жёсткий диск не начнёт показывать проблемы. Конечно, многие проблемы могут возникать задолго до достижения этого порога. Например, изучение и перераспределение данных с плохой (повреждённой) области может занять много времени (даже часов), и этот процесс не может быть завершён без проблем. Во время него система, как правило, ни на что не реагирует, поэтому проблематичный жёсткий диск, создавая проблемы снова и снова, может существенно снизить общую стабильность системы.

Анализатор жёстких дисков большинства приложений использует вышеуказанный метод для определения состояния здоровья. Во многих случаях, состояние жёсткого диска отображается намного лучше фактического из-за умеренных пороговых значений. Некоторые производители могут изменять значения, чтобы показать состояние здоровья своего драйвера лучше других. Это может ввести в заблуждение некоторые программы или пользователей.

Важно, что если один из атрибутов S.M.A.R.T. достигает порогового уровня, то жёсткий диск будет работать в течение 24 часов (для возможности запуска резервного копирования). В большинстве случаев этого недостаточно и лишь часть данных может быть сохранена за это время. Сохранение данных проблематично на почти неработающем жёстком диске, этот процесс может быть весьма длительным и дорогостоящим. Лучше выявить и подготовиться к проблеме заранее, не доводя ситуацию до катастрофы.

Анализ исходных значений

Hard Disk Sentinel была разработана для преодоления этой ситуации. Заданные по умолчанию методы оценки проверяют исходные значения атрибутов S.M.A.R.T. Таким образом можно определить здоровье жёстких дисков независимо от производителя и модели.

Примечание: можно выбрать производителя с конкретным методом оценки в расчётах состояния. Однако постоянное использование такого метода не рекомендуется (из-за проблем описанных выше), поскольку он может выдать не надлежащие результаты.

При обработке исходных значений не существует конкретного (определённого производителем) порога для атрибутов. Однако растущие проблемы уменьшают здоровье диска (постоянно и внезапно), что предсказывает возможный отказ и потерю данных.

Подробное описание методов вычисления описаны здесь.


Ðàñ÷¸ò çäîðîâüÿ

Расчёт здоровья

Можно выбрать разные методы расчёта здоровья на вкладке расширенные опции. Различия между этими методами оценки заключаются в следующем:

Анализ области данных

Если выбрана эта опция, то исходные измеренные значения (отображаемые в колонке Данные для соответствующего атрибутов S.M.A.R.T.) будут использоваться для определения здоровья жёсткого диска. При разработке метода расчёта важными являются следующие аспекты:

· Они обязаны отражать фактическое состояние. Не должны зависеть от времени или предыдущих значений. Определять результат без использования длительных методов анализа и тестирования.

· Со временем они не должны возрастать - не показывать состояние здоровья лучше первоначального значения (за исключением случаев, когда некоторые необработанные сектора были успешно проверены и могут использоваться, поскольку не имеют проблем).

.

· Они должны отражать небольшие изменения и ухудшения. Постоянно растущее число проблем должно уменьшать результат.

· Они обязаны учитывать взаимосвязь между атрибутами. Большое количество различных проблем должно привести к быстрому снижению результатов, в отличии от одного проблематичного атрибута.

· Результат должен быть идентичным для двух (или более) жёстких дисков с одинаковыми проблемами, даже если они разных моделей и производителей.

· В некоторых ситуациях результат должен быть контролируемым. Например, после замены неисправного блока питания, проблемы, которые возникли ранее следует игнорировать. Кроме того, показания ненадёжного датчика также следует игнорировать или его значение должно быть изменено (смотрите раздел калибровка температуры).

Жёсткий диск имеет 100% состояние на первоначальном этапе. Все критические параметры оценки здоровья S.M.A.R.T. (если они имеются, что зависит от производителя) уменьшают это значение. Эти атрибуты имеют предварительно определённое и предельное значения (последнее определяет наихудшее значение атрибута). Процентное состояние здоровья рассчитывается путем умножения значений оставшихся процентов (100% - полная деградация).

В настоящее время Hard Disk Sentinel может использовать два разных метода. Использование метода по умолчанию, определённого и предельного значений (см. ниже), всегда легче. Если при более точном методе, который рекомендуется для серверов, использовать опцию точного определения значения, то это может снизить здоровье радикальным образом.

В приведенных ниже таблицах содержатся критические атрибуты S.M.A.R.T., связанные со здоровьем. Они затрагивают здоровье с определёнными и предельными значениями:

Определённые и предельные значения для метода расчёта по умолчанию:

Атрибуты S.M.A.R.T. | Определённый | Предельный %
Reallocated sectors count | 1 | 70
Seek error rate | 0.5 | 20
Spin retry count | 3 | 60
Reallocation event count | 0.6 | 30
Current pending sectors count | 0.6 | 48
Off line uncorrectable sectors count | 1 | 70

Определённые и предельные значения для более точного метода расчёта:

Атрибуты S.M.A.R.T. | Определённый | Предельный %
Reallocated sectors count | 6 | 60
Seek error rate | 2 | 20
Spin retry count | 6 | 40
Reallocation event count | 4 | 30
Current pending sectors count | 4 | 30
Off line uncorrectable sectors count | 6 | 60

Значения определены путём изучения отчётов и состояния S.M.A.R.T. (непригодных) жёстких дисков, полученных для восстановления данных.

Примечание: колонка Данные содержит шестнадцатеричные значения, которые перед расчётом должны быть преобразованы в десятичный формат. Нижние 16 бит (крайние правые 4 цифры) используются при расчётном методе.

Например: При использовании метода расчёта по умолчанию. Если значение атрибута "Reallocated sectors count" в колонке "Данные" равно 0002, то значение здоровья будет: 100 х (100 - 2x1)% = 98%

Если атрибут "Current pending sectors count" имеет значение 0005 в колонке "Данные" на том же жёстком диске, то здоровье будет: 98 x ( 100 - 5x0.6) % = 95 %. Более точный метод вычисления даёт: 100 x (100 - 2x6) % x (100 - 5x4) % = 70 %, как результат значения здоровья.

Процентный предел определяет какой процент атрибута может уменьшить общее значение здоровья. Например, если атрибут "Off line uncorrectable sectors" содержит значение 0200 в колонке "Данные" (которое равно 512, если преобразовать в десятичное значение), то здоровье должно уменьшиться на 512 х 1 = 512%, но предел для этого атрибута составляет только 70%. Другими словами, если значение данного атрибута высокое, то значение здоровья диска не может быть больше 30%. Другие проблемы могут уменьшить значение здоровья гораздо значительнее.

Анализ значений, определённых производителем

Если выбрана эта опция, то будут оценены связанные со здоровьем атрибуты S.M.A.R.T. У всех этих атрибутов будет небольшое значение состояния, вычисленное между 0 и 100%, основанное на фактическом значении, пороге и теоретически максимальном значении (последнее определяется Hard Disk Sentinel на основе производителя и модели). Умножение этих значений даст оценку общего состояния здоровья жёсткого диска.

Например: порог для атрибута "Reallocated sectors count" составляет 36, значение - 84, а начальное значение этого атрибута было равно 100. Значит значение состояния этого атрибута: (1 - (100-84) / (100-36)) х 100 = 75%. Если (на том же жёстком диске) порог для "Seek Error Rate" равен 30, значение 60, а начальное значение 90, то состояние этого атрибута будет составлять 50%, а общее состояние здоровья жёсткого диска 37,5 %.

Примечание: В версии 1.40 (и предыдущих) Hard Disk Sentinel применяет только более точный метод, который рекомендуется для расчёта на серверах. Обновление этих версий приведёт к отображению других значений здоровья. На вкладке расширенные опции в любое время можно изменить метод расчёта.

Примечание: выбранный метод расчёта сохраняется в отчётах, чтобы избежать путаницы.

Примечание: обычно различные значения здоровья следуют из формулы:

Определённое производителем ≥ По умолчанию ≥ Более точное

С помощью "более точного" метода значение здоровья резко падает в случае каких-либо небольших проблем, поэтому использование этого метода рекомендуется только тогда, когда не допускается (даже маленькая) проблема.


Ðàñ÷¸ò ïðîèçâîäèòåëüíîñòè

Расчёт производительности

Значение производительности жёсткого диска может быть рассчитано по-разному (как и значение здоровья). Опция Метод вычисления состояния на вкладке расширенные опции определяет, какой метод будет использоваться при расчёте оценки производительности.

Анализ области данных

Hard Disk Sentinel оперирует разными значениями для определения этой оценки. Исходные значения производительности, связанные с атрибутами S.M.A.R.T. (например, время позиционирования головок) влияют на общую производительность максимум на 25%. Количество ошибок передачи данных (ошибки CRC Ultra ATA), найденные за последний месяц, могут также привести к падению значения производительности на 25%. Эти ошибки передачи данных не указывают на реальные проблемы с жёстким диском, но они могут уменьшить стабильность и производительность системы.

Остальные 50% производительности рассчитываются путём изучения используемых в настоящее время режима передачи DMA и режима максимально доступной передачи. Если жёсткий диск работает только в режиме PIO (программируемый контроллер ввода/вывода), то значение этой части условия будет равно 0 вместо 50.

Например: если скорость передачи данных в режиме Ultra DMA составляет только 2 (33 Мб/с) вместо доступной максимальной скорости передачи данных Ultra DMA - 5 (100 Мб/с), но производительность, связанная с атрибутами S.M.A.R.T., правильная и без ошибок передачи данных за прошлый месяц, то полное значение производительности будет составлять: 25 + 25 + (2/5) х 50 = 70%. В этом примере, проблема, вероятнее всего, связана с использованием старого 40-жильного кабеля IDE.

Анализ значений, определённых производителем

Если выбрана эта опция, то будут оценены связанные с производительностью атрибуты S.M.A.R.T. Все эти атрибуты имеют значения, рассчитанные между 0 и 100%, основанные на фактическом значении, пороге и теоретически максимальном значении (последнее определяется Hard Disk Sentinel на основе производителя и модели). Умножение этих значений даст полное значение состояния производительности жёсткого диска.


Âðåìÿ ðàáîòû, âðåìÿ æèçíè

Время работы

Время работы жёсткого диска может быть определено при исследовании атрибута S.M.A.R.T №9 "Power On Time Count". Это значение поддерживается большинством современных IDE и S-ATA жёстких дисков.

Исходное значение этого атрибута постоянно растёт, если жёсткий диск запущен, но не обязательно выполняет операции чтения/записи. Единица времени зависит от производителя. Это может быть час (значение увеличивается каждый час), минута или полминуты. Возможно также различное измерение единицы времени у двух жёстких дисков одного и того же производителя.

Сразу после установки Hard Disk Sentinel начинает изучение этого атрибута. Он проверяет прошедшее время между двумя последовательными увеличениями исходного значения этого атрибута. Во время этого теста оценивается значение времени работы, что отображается серым цветом, но оно не может быть точным. Этот тест может продолжаться до 20 минут. Если пользователь закроет приложение во время этого процесса, то тест будет автоматически перезапущен при следующем запуске Hard Disk Sentinel, пока не будет определена единица измерения и время работы всех жёстких дисков. После этого, единица измерения времени сохраняется и позже используется автоматически. Это измерение не влияет на производительность жёсткого диска или компьютера.

После измерения (или если не требуется) значение точного времени работы будет отображаться чёрным цветом, а текст "приблизительная оценка" исчезнет. Если вам кажется, что отображается неверное значение (слишком низкое или высокое), то можно использовать кнопку "Повтор Теста".

Когда измерение завершится, рекомендуется отправить отчёт о тестировании. разработчику. Полученные отчёты помогут в дальнейшем развитии программы и, вполне возможно, что в более поздних версиях значения точного времени работы будут отображаться с первого раза (без необходимости их измерения).

Значение, показанное рядом с надписью Время работы, указывает полное время работы диска со дня его установки. Время простоя (когда не было операций чтения/записи) также увеличивает это значение, а время ожидания нет. Один отображаемый день означает 24 часа. Например, двухлетний жёсткий диск, который используется 12 часов каждый день, будет показывать то же самое "Время работы" как и однолетний, который работает круглосуточно (или как 3-летний жёсткий диск, используемый по 8 часов в день).

Примечание: время работы на некоторых моделях может отображаться неправильно.

Предполагаемое время жизни

Анализ области данных

Если на вкладке Расширенные опции выбран вариант "Анализ области данных" в качестве метода расчёта состояния, то оставшееся время работы рассчитывается следующим образом:

· По умолчанию, общий ожидаемый срок службы жёсткого диска в идеальном состоянии определён в 5 лет (работает круглые сутки). Он равен 1825 дням в режиме 24/7 или 43800 часов.

· Прошедшее время работы уменьшает это значение.

· Результат уменьшается на количество дней, когда температура была слишком высокой. Если максимальная (пиковая) температура была высокая, то это не столь критично. Но если средняя температура была слишком высокой (температура была высокой длительное время), то результат значительно сократится.

· Результат умножается на квадрат значения здоровья жёсткого диска.

Примечание: Hard Disk Sentinel отображает 1000 дней, как максимальное значение оставшегося времени работы. Конечно, в идеале это значение не уменьшится даже после 100 дней.

Например: жёсткий диск работает в течение 600 дней (600 x 24 часа), и его температура не была слишком высокой (не было дней со слишком высокой средней температурой), и здоровье составляет 70 %. Всего оставшегося времени работы: 1225 x 0.7 x 0.7 = 600 дней и 6 часов.

Отсюда видно, что именно значение здоровья окончательно определяет предполагаемое время оставшейся жизни жёсткого диска. Если значение здоровья будет низким, то оставшийся срок эксплуатации всё равно будет оставаться неизменным в течение многих дней, даже если значение времени работы увеличивается. Например, если значение здоровья составляет 25%, то необходимо 16 дней (при условии круглосуточной работы жёсткого диска), чтобы уменьшить оставшееся время работы всего на один день (потому что 16 x 0.25 x 0.25 = 1)

Примечание: предполагаемая оставшаяся жизнь зависит от многих факторов (температура, здоровье), таким образом, рекомендуется выполнить калибровку температуры и выбрать правильный метод расчёта состояния, основанный на фактической ситуации, а также при необходимости использовать правильные значения смещения для атрибутов S.M.A.R.T. Только опытным пользователям следует использовать и изменять эти опции, потому что некорректная их установка может привести к неправильному отображению значений.

Анализ значений, определённых производителем

Если используется опция "Анализ специальных значений" (значения от производителя), то предполагаемое время жизни, определяемое порогом будет превышать дату критического значения атрибута S.M.A.R.T. Такой порог превышает даты, отображённые на графиках атрибута S.M.A.R.T. жёсткого диска, если выбрана опция "Специальные значения поставщика" (рядом с графиком).

Примечание: этот метод будет надёжным, только если Hard Disk Sentinel постоянно анализирует жёсткие диски в течение длительного времени (несколько недель или даже месяцев). В других случаях, возможно неправильное предсказание результата с небольшим ухудшением состояния атрибутов (например, дата превышения порога будет в январе 2100. Конечно, это не реально, но такие значения могут появляться и в других приложениях, которые ведут мониторинг жёстких дисков). Чтобы избежать такой ситуации, Hard Disk Sentinel отображает значение в 1000 дней, как максимальное значение для оценки остаточного ресурса. Конечно, в идеале это значение не уменьшится даже после 100 дней.


Êàëèáðîâêà òåìïåðàòóðû

Калибровка температуры

Встроенный датчик температуры в большинстве современных жёстких дисков может показывать неверные результаты. Разница между измеренной и фактической температурой может быть в 7-9 градусов Цельсия, а в некоторых случаях даже ещё больше.

Чтобы решить эту проблему, рекомендуется измерить фактическую температуру жёсткого диска с помощью внешнего инфракрасного термометра или лицевой панели с датчиком температуры. А затем установить разницу между измеренным значением и температурой, которую отображает Hard Disk Sentinel (по сообщению самого диска), как температурное смещение. Это называется калибровкой.

После измерения реальной температуры (термометром или другим внешним датчиком) смещение можно рассчитать путём вычитания значения, указанного программой из измеренного значения. Смещение может быть положительным (программа показывает меньшую температуру, чем реальная) или отрицательным (в противном случае).

Это смещение можно указать на вкладке S.M.A.R.T. жёсткого диска, выбрав атрибут № 194 (температура жёсткого диска) и используя кнопки + / - (нажав на число между этими знаками, можно непосредственно ввести значение смещения по Цельсию).

Hard Disk Sentinel автоматически увеличивает (или уменьшает) все сообщённые значения температуры жёсткого диска согласно настроенным смещениям. Таким образом, правильная (реальная) температура будет отображаться в любом случае (например, при сравнении температуры жёсткого диска с пороговым значением, при сохранении отчётов и т.д.)

Рекомендуется выполнить калибровку температуры на всех установленных жёстких дисках, если это возможно. Одинаковый тип жёстких дисков может потребовать разные смещения температуры.

Примечание: если калибровка невозможна (компьютерный блок нельзя открывать), предполагаемое значение смещения можно определить, сравнивая первое отображённое значение температуры сразу после запуска компьютера со значением температуры окружающей среды (комната, офис). В это время центральный процессор, видеокарта или другие компоненты не слишком горячие и не влияют на значение температуры жёсткого диска. Конечно, это справедливо только если компьютеру было предоставлено достаточно времени, чтобы остыть до температуры окружающей среды (не включался около 8 часов).

Например, если температура жёсткого диска равна 17 градусов по Цельсию (сразу после запуска компьютера), а температура в помещении 22 градуса, то эта разница (5) может быть настроена как значение смещения (потому что жёсткий диск не может быть прохладнее, чем окружающая температура) . Это смещение лучше, чем ничего, но всё же внешний термометр необходим для определения надлежащего смещения температурного значения.

Примечание: температурное смещение должно определяться по Цельсию, независимо от выбранной единицы измерения температуры (по Цельсию или по Фаренгейту).

Примечание: незарегистрированная версия программы автоматически сбрасывает все значения смещения на 0, если пользователь перезагрузил Hard Disk Sentinel.


Àòðèáóòû S.M.A.R.T.

Список атрибутов S.M.A.R.T. (ATA)

Это список всех известных атрибутов, поддерживаемых жёсткими дисками интерфейсов IDE и Serial ATA.

Примечание: некоторые производители также могут использовать и другие атрибуты для различных целей. Те атрибуты, которые здесь не перечислены являются атрибутами "определёнными производителем" (их цель не известна).

1 | Raw Read Error Rate | Ошибки, произошедшие при чтении данных с диска. Указание на проблему с поверхностью диска или головками чтения/записи. Критический атрибут
2 | Throughput Performance | Общая производительность жёсткого диска. Указание на проблему с двигателем, сервомотором или подшипниками.
3 | Spin Up Time | Время, необходимое шпинделю для набора полных оборотов. Указание на проблему с двигателем или подшипниками. Критический атрибут
4 | Start/Stop Count | Счётчик циклов пуска/остановки шпинделя. Это значение не затрагивает непосредственно состояние диска.
5 | Reallocated Sector Count (Reallocated Sectors Count) | Счётчик секторов, перемещённых в резервную область. Указание на проблему с поверхностью диска или головками чтения/записи. Критический атрибут
6 | Read Channel Margin | Запас канала чтения данных. Точная функция этого атрибута не определена.
7 | Seek Error Rate | Ошибка скорости позиционирования головок чтения/записи. Указание на проблему с сервомотором или головкой. Высокая температура также вызывает такую проблему. Критический атрибут
8 | Seek Time Performance | Среднее время позиционирования головок. Указание на проблему с сервомотором. Критический атрибут
9 | Power-On Time Count | Полное время работы диска. Единица измерения зависит от производителя.
10 | Spin Retry Count | Счётчик повторных попыток начала вращения. Указание на проблему с двигателем, подшипниками или блоком питания. Критический атрибут
11 | Drive Calibration Retry Count | Количество попыток рекалибровки диска. Указание на проблему с двигателем, подшипниками или блоком питания.
12 | Drive Power Cycle Count | Количество завершённых циклов включения/выключения. Это значение не затрагивает непосредственно состояние диска.
13 | Soft Read Error Rate | Количество программных ошибок чтения. Количество неисправимых ошибок чтения.
184 | End-to-End error | Количество ошибок чётности во время передачи между кэшем RAM и хостом.
187 | Reported Uncorrectable Errors | Ошибки, которые не могут быть восстановлены аппаратным методом.
188 | Command Timeout | Количество прерванных операций из-за тайм-аута HDD. Значение больше нуля может указывать на проблемы с блоком питания или кабелем передачи данных.
189 | High Fly Writes | Количество опасных операций записи вне нормального диапазона подвода головки.
190 | Airflow Temperature | Температура потока воздуха. Температура воздуха внутри жёсткого диска.
191 | Mechanical Shock | Количество механических ошибок. Количество ошибок от встряски или вибрации.
192 | Power off Retract Cycle | Счётчик циклов включения питания. Это значение не затрагивает непосредственно состояние диска.
193 | Load/Unload Cycle Count | Счётчик циклов загрузки/разгрузки. Количество циклов перемещений головки в зоне посадки.
194 | HDD Temperature | Температура диска. Температура внутри жёсткого диска.
195 | Hardware ECC Recovered | Счётчик исправимых ошибок. Количество ошибок, исправленных встроенным механизмом исправления ошибок.
196 | Reallocation Event Count | Счётчик операций переназначения секторов. Количество всех (успешных и нет) операций переназначения. Критический атрибут
197 | Current Pending Sector Count | Счётчик нестабильных секторов. Эти сектора, ожидающие обработки, могут быть повторно отображены в резервной области. Критический атрибут
198 | Off-Line Uncorrectable Sector Count | Счётчик неисправимых ошибок чтения/записи. Указание на проблему с поверхностью диска или головками чтения/записи. Критический атрибут
199 | Ultra ATA CRC Error Count | Счётчик ошибок при передаче данных между диском и хостом. Указание на проблему с блоком питания или кабелем данных.
200 | Write Error Rate | Ошибки, произошедшие при записи исходных данных с диска. Указание на проблему с поверхностью диска или головками чтения/записи.
201 | Soft Read Error Rate | Количество программных ошибок чтения. Количество неисправимых ошибок чтения.
202 | Data Address Mark Errors | Количество ошибок метки адреса данных. Количество неправильных или недопустимых меток адреса.
203 | Run Out Cancel | Количество ошибок исправления данных. Недопустимая контрольная сумма исправления, найденная во время исправления ошибок.
204 | Soft ECC Correction | Количество исправленных ошибок данных. Ошибки, исправленные встроенным механизмом исправления.
205 | Thermal Asperity Rate | Количество термических проблем. Общее количество проблем, вызванных высокой температурой.
206 | Flying Height | Поднятие головки. Высота поднятия головок над поверхностью диска.
207 | Spin High Current | Текущее значение набора оборотов. Поточная скорость вращения диска.
208 | Spin Buzz | Количество циклов набора оборотов. Количество повторений во время набора оборотов из-за слабой доступности.
209 | Offline Seek Performance | Производительность диска во время автономных операций. Производительность подвода головки диска во время внутреннего самотестирования.
211 | Vibration During Write | Столкновение с вибрацией во время операций записи.
212 | Shock During Write | Столкновение с сотрясением во время операций записи.
220 | Disk Shift | Смещение диска относительно шпинделя. Неправильное дисковое вращение может быть вызвано механическим ударом или высокой температурой.
221 | G-Sense Error Rate | Количество механических ошибок. Количество ошибок, вызванных ударом или вибрацией.
222 | Loaded Hours | Время работы диска. Учитывается период, в течении которого головки были в рабочем положении. Это значение постоянно увеличивается (раз в час).
223 | Load/Unload Retry Count | Количество операций загрузки/разгрузки. Количество ввода/вывода головки в зону данных.
224 | Load Friction | Механический фрикционный показатель. Показатель трения между механическими частями. Указание на проблему с механической подсистемой диска.
226 | Load-in Time | Полное время загрузки головок. Время чтения/записи головок в зоне данных.
227 | Torque Amplification Count | Показатель увеличения вращающего момента. Увеличение вращающего момента во время операции набора оборотов диска.
228 | Power-off Retract Count | Количество циклов включения питания. Количество отказов головки в результате выключения питания.
230 | GMR Head Amplitude | Амплитуда позиционирования головки. Перемещение головки между операциями.
231 | Hard Disk Temperature | Температура диска. Температура внутри жёсткого диска.
240 | Head Flying Hours | Время позиционирования головок. Время, затраченное на позиционирование головок диска.
250 | Read Error Retry Rate | Количество повторений операций чтения. Количество ошибок, найденных во время чтения сектора с поверхности диска.
254 | Free Fall Event Count | Количество событий свободного падения, обнаруженных датчиком акселерометра.

Список атрибутов S.M.A.R.T. (SCSI)

Это список всех известных атрибутов, поддерживаемых жёсткими дисками SCSI.

Примечание: некоторые производители также могут использовать и другие атрибуты для различных целей. Те атрибуты, которые здесь не перечислены являются атрибутами "определёнными производителем" (их цель не известна).

01 | Буфер над/под запущенных счётчиков
02_0000 | Ошибки записи, исправленные без существенной задержки
02_0001 | Ошибки записи, исправленные с возможными задержками
02_0002 | Всего ошибок записи
02_0003 | Всего исправленных ошибок записи
02_0004 | Всего ошибок записи, исправленных алгоритмом
02_0005 | Всего записано байт
02_0006 | Всего неисправленных ошибок записи
03_0000 | Ошибки чтения, исправленные аппаратным методом ECC
03_0001 | Ошибки чтения, исправленные с возможными задержками
03_0002 | Всего ошибок чтения
03_0003 | Всего исправленных ошибок чтения
03_0004 | Всего ошибок чтения, исправленных алгоритмом
03_0005 | Всего прочитано байт
03_0006 | Всего неисправленных ошибок чтения
04_0000 | Ошибки обратного чтения, исправленные аппаратным методом ECC
04_0001 | Ошибки обратного чтения, исправленные с возможными задержками
04_0002 | Всего ошибок обратного чтения
04_0003 | Всего исправленных ошибок обратного чтения
04_0004 | Всего ошибок обратного чтения, исправленных алгоритмом
04_0005 | Всего байт обратного чтения
04_0006 | Всего неисправленных ошибок обратного чтения
05_0000 | Проверенные ошибки исправлены без существенных задержек
05_0001 | Проверенные ошибки исправлены с возможными задержками
05_0002 | Всего проверено ошибок
05_0003 | Всего проверенных, исправленных ошибок
05_0004 | Всего проверенных ошибок, исправленных алгоритмом
05_0005 | Всего проверено байт
05_0006 | Всего проверенных, неисправленных ошибок
06_0000 | Не ошибки среды
07 | Последняя ошибка
0B | Последняя отложенная ошибка или асинхронное событие
0D_0000 | Температура
0D_0001 | Исходная температура
0E_0001 | Дата производства (год/неделя)
0E_0002 | Расчётная дата
0E_0003 | Указанный цикл счёта всей жизни устройства
0E_0004 | Накопленные циклы запуска/остановки
0F | Данные параметра приложения клиента
10 | Лог результатов самотестирования
18 | Лог протокола специфического порта
37_0000 | Блоки, отправленные инициатору
37_0001 | Блоки, полученные от инициатора
37_0002 | Чтение блоков из кэша и отправление инициатору
37_0003 | Ввод/вывод меньшего размера, чем размер сегмента
37_0004 | Ввод/вывод большего размера, чем размер сегмента
3E_0000 | Время работы
3E_0008 | Остаток минут до следующего внутреннего теста


Òåêñòîâîå îïèñàíèå

Текстовое описание

Hard Disk Sentinel анализирует атрибуты, предоставленные диском, и на основе оценок этих значений создаёт и выводит на экран текстовое описание. В нём может содержаться ряд проблем, возникших в ходе всего срока службы жёсткого диска, проблем набора оборотов, ошибок передачи данных и т. д. Цвет фона этой области (зелёный, жёлтый, красный) указывает на состояние здоровья диска. Текстовая область может содержать советы для решения проблем, поэтому мы рекомендуем подробно с ними ознакомиться.

Что Такое Следующий Шаг?

Если уровень здоровья диска ниже 100 %, это не обязательно означает катастрофу. Отображаемое значение здоровья вычисляется на основе всех проблем, когда-либо найденных за весь срок эксплуатации жёсткого диска. Все эти проблемы регистрируются во внутренней базе данных (таблица S.M.A.R.T.) диска, а Hard Disk Sentinel считывает и отображает их.

В первую очередь необходимо проверить, что эти проблемы являются фактическими - или они были только что установлены, или ситуация уже исправлена. Например, если отображаются сбойные сектора, то они не должны больше использоваться на жёстком диске и к ним нельзя получить доступ с помощью любых средств (используется резервная область вместо проблемных секторов). Именно поэтому сканирование поверхности диска сторонними приложениями (например, scandisk) не показывает никаких проблем, потому что они тестируют также и резервную область (смотри ниже).

Кроме того, если отображается проблема набора оборотов (которая может быть вызвана слабым блоком питания или проблемой с основной линией электропитания), и это уже исправлено (например, блок питания заменён или установлен ИБП), то такие проблемы больше не являются значительными.

Самое главное убедиться в стабильном состоянии жёсткого диска. Необходимо определить, как значение здоровья изменяется при высокой нагрузке и во время длительного использования. Если значение здоровья не слишком высокое, но стабильное (не изменяется), то ранее выявленные проблемы могут быть проигнорированы, так как диск больше не использует перераспределенные сектора, а новые сбойные/слабые сектора не обнаружены (если это содержится в текстовом описании).

Лучшим методом для безопасности данных является тест аппаратными средствами, которым можно проверить стабильность текущей ситуации. Различные тесты могут быть запущены из меню Файл. Они рассматривают компоненты диска (головки, сервомотор, прошивку, внутреннюю память), а расширенная самодиагностика дополнительно проверяет все области поверхности диска. Если такие тесты завершаются без проблем (даже если здоровье диска ниже 100 %), то ситуацию можно считать стабильной.

Если какой-либо из тестов показывает проблемы, рекомендуется использовать различные методы расширенного тестирования. Хорошим примером является полная перезапись поверхности диска (а не только выполнение теста чтения). Это можно сделать тестом поверхности, входящего в программу Hard Disk Sentinel. Лучше всего использовать метод Повторной инициализации диска, но доступны также и другие тесты для проверки поверхности диска. Тесты записи гораздо лучше, поскольку они более эффективно обнаруживают и устраняют проблемы.

Если значение здоровья и текстовое описание являются постоянными и не изменяются после тестов в течение длительного времени, то нынешние проблемы могут быть очищены. Таким образом, программа больше не будет их показывать, а только учитывать количество новых появившихся проблем, и пока новая проблема не будет найдена, значение здоровья останется равным 100%.

Чтобы удалить существующие проблемы, пожалуйста, откройте вкладку S.M.A.R.T. диска и найдите атрибут(ы) с указанием каких-либо проблем (они отмечены знаком [image] ). Нажмите на колонку "Смещение" и введите отрицательное значение, тогда изменения можно увидеть и в колонке "Данные" в этой же строке (и в текстовом описании диска). Например, если отображено, что перераспределено 5 секторов, то укажите значение -5 в колонке смещение для соответствующего атрибута. Пожалуйста, посмотрите страницу калибровка температуры для получения более подробной информации об использовании смещений.

В любом случае, рекомендуется постоянно следить за такими дисками, особенно, если несколько различных проблем и/или слабых секторов отображено в текстовом описании. Такой мониторинг позволяет обнаружить любые (даже небольшие) новые проблемы и, в таких случаях, даёт возможность выполнить резервное копирование. Версия программы PROFESSIONAL может делать это автоматически.

Если уровень здоровья низкий, но выше 0%, то это не является гарантийным случаем и не даёт право на замену диска. В таком случае (независимо от фактического состояния здоровья или результатов теста) диск может иметь "слишком мало" проблем с точки зрения производителя - с такой формулировкой они обычно отказываются от гарантийной замены.

Как правило, замена по гарантии возможна только в том случае, если количество проблем очень высоко и достигает порогового уровня, указанного производителем. Таким образом, значение здоровья должно упасть до 0%.

Важно знать, что серьёзное тестирование (особенно аппаратными средствами) может выявить больше проблем и тем самым значительно снизить значение здоровья.

Можно использовать тестовые приложения, предоставляемые производителем для проверки состояния диска. Важно знать, что некоторые из них в действительности не устанавливают, а только скрывают проблемы, которые могут появиться при последующем использовании. Именно поэтому настоятельно рекомендуется постоянно следить за состоянием диска после завершения тестирования программным обеспечением от производителя - особенно, если значение здоровья меняется в любом направлении.

Сбойные сектора?

Что такое "сбойный сектор"? Как они появляются и как их можно устранить? Пользователи смущены, поскольку проверка поверхности диска программами (например, Windows Scandisk) не сообщает ни о каких проблемах или сбойных секторах.

S.M.A.R.T. постоянно анализирует поверхность диска во время нормального функционирования. Если он находит проблематичную область (один или несколько секторов, где данные на диске трудно читать или записывать), то программа пытается прочитать данные и скопировать их (перераспределить) в резервную область. Тогда прежнее место расположения помечается как плохое и все дальнейшие операции чтения/записи, указывающие на это место, перенаправляются в резервную область.

Когда операция завершится, оригинальная (плохая) область не будет больше доступна программному обеспечению. Даже переустановка или полное форматирование не будет показывать проблемы, поскольку первоначально плохие области больше не используются. Поэтому программное обеспечение (например, Scandisk Windows ') не найдёт проблематичных секторов. Только функция удаления в аппаратной защите может получить доступ к этой области (очистка этих секторов).

Именно поэтому из-за S.M.A.R.T., например команда "format" в DOS никогда не покажет сбойные сектора на большинстве современных жёстких дисков (за исключением, если резервная область заполнена, но такой жёсткий диск действительно трудно найти).

Перераспределение секторов может быть завершено с ошибками или без них (теперь жёсткие диски работают гораздо лучше старых моделей). Но процедура перераспределения может привести к нестабильности системы, если она занимает слишком много времени.

Пользователь не должен обращать внимание на шаги, описанные выше. Именно тогда, когда количество повреждённых секторов станет достаточно высоким (будет достигнут порог), S.M.A.R.T. спрогнозирует возможный отказ.

Очень небольшая царапина или пятнышко на поверхности диска могут вызвать образование сбойных секторов. Обычно, если количество таких секторов является низким, они не приводят к большим проблемам. Но если их число постоянно возрастает (отображаемое значение здоровья уменьшается), то это может привести к отказу. Рекомендуется постоянно следить за состоянием своего жёсткого диска, если его показатели не равны 100%.

Тест Жёсткого Диска

Рекомендуется периодически анализировать и проверять состояние диска (особенно, если жесткий диск не идеален, а здоровье составляет менее 100 %). Лучшим методом является запуск аппаратной Расширенной самодиагностики, которая сможет проанализировать компоненты жёсткого диска и всю поверхности диска. Прочие (программные) тесты не могут так детально проверить жёсткий диск. Этот (и другие поддерживаемые аппаратные тесты) могут быть запущены вручную на вкладке Информация или автоматически (по расписанию) на вкладке Операции (только в версии Professional).